Results 1 to 3 of 3
  1. #1

    hey guys new to the forum

    hey i have a 2004 seadoo gtx with 214 hrs runs good only problem is my gauges stop working and i tryed all of the fuses and the connections and still no luck when i put the key on i get a long beep like it knows the gauges arnt working i cant post on the classified cause i havent posted enough yet any help or pointers would be a big help thanx

  2. #2
    masta2000's Avatar
    Join Date
    Aug 2009
    plug it in at your dealers to the buds, maybe you need to reactivate it

  3. #3

    u can do that ?

    they can reactivate it ?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Hey everyone new to forum with some ?'s on 04 gtxsc
    By mooneyb91084 in forum 4-Tec Performance
    Replies: 16
    Last Post: 03-08-2007, 05:47 PM
  2. Hey guys new to forum
    By surfer483 in forum 4-Tec Performance
    Replies: 18
    Last Post: 11-03-2006, 10:23 AM
  3. hey guys
    By redemn93 in forum Sea Doo Open Discussion
    Replies: 12
    Last Post: 08-29-2006, 09:53 PM
  4. HEy Guys Need Help PLEASE!!!
    By SpeedStang95 in forum 4-Tec Performance
    Replies: 5
    Last Post: 05-06-2006, 01:29 AM
  5. Hey guys!
    By dgmoore in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 05-03-2005, 08:51 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts