Results 1 to 3 of 3
  1. #1

    hey guys new to the forum

    hey i have a 2004 seadoo gtx with 214 hrs runs good only problem is my gauges stop working and i tryed all of the fuses and the connections and still no luck when i put the key on i get a long beep like it knows the gauges arnt working i cant post on the classified cause i havent posted enough yet any help or pointers would be a big help thanx


  2. #2
    masta2000's Avatar
    Join Date
    Aug 2009
    Location
    montreal-quebec
    Posts
    576
    +1
    1
    plug it in at your dealers to the buds, maybe you need to reactivate it

  3. #3

    u can do that ?

    they can reactivate it ?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Did I smoke my motor? Oh yea, Hi guys new to the forum.
    By 800n in forum Yamaha PWC Performance (2-stroke)
    Replies: 19
    Last Post: 04-29-2013, 12:39 PM
  2. Hey guys, new to the forum and have a question
    By GPRhollic in forum Yamaha PWC Performance (2-stroke)
    Replies: 8
    Last Post: 02-15-2011, 07:50 AM
  3. Hey guys new to forum
    By surfer483 in forum 4-Tec Performance
    Replies: 18
    Last Post: 11-03-2006, 10:23 AM
  4. So... New to the forum, looking to buy an RXP
    By GGIII in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 07-18-2006, 12:41 PM
  5. New to the forum...got some questions
    By BlackHawk in forum 4-Tec Performance
    Replies: 11
    Last Post: 03-20-2006, 05:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •