Results 1 to 8 of 8
  1. #1

    Join Date
    May 2010
    Location
    Tampa, FL
    Posts
    127

    Help please wrong fuel pump?

    I bought a mikuni high volume from SBT but to my surprise when i was going to use it. It only has 4 outlet!!!!! my jetski is a polaris slx 780 1996. and old full pump is 5 outlet!!! 3 - 1 for each carburetor 1 connected to inline and the other to motor. thats the old 1 and the new one?????? 1 motor 1 inline and 2 carburetors? is this suppose to be like that? the website is pwctoday.com i order it from them. but now im stuck. please help and tell me if i have to adapt something etc. or if i bougth wrong 1


  2. #2
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,328
    +1
    29
    You probably bought the dual outlet. That's fine.

    Just "T" each supply hose to the CEN carb.

  3. #3

    Join Date
    May 2010
    Location
    Tampa, FL
    Posts
    127
    will that work as good? also.... the pto carburetor has a bigger hole where the high speed screw adjuster is. so now when i turn the ski on it constantly stay accelarated do to the fact that is throwin little big of gas through there. any help please? do i need to replace the carb or is there a way to avoid this? maybe making hole smaller and how please.

  4. #4
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,328
    +1
    29
    "T" the fuel lines should be fine.

    Need a pic for what you're talking about. I have no idea what you mean.

  5. #5
    Bing-A-Ding-Ding-Ding, Brrrrrap! Brrrrrrrrrap!!! Polaris_Nut#1's Avatar
    Join Date
    Aug 2006
    Location
    Pittsfield, MA
    Posts
    3,350
    +1
    26
    yeah pic please, I'm lost

  6. #6

    Join Date
    May 2010
    Location
    Tampa, FL
    Posts
    127
    Guys if i T the dual outlet fuel pump will it work as good or no? Also yesterday my 780 ran 60mph after rebuilded carbs and new gaskets and good clean out of all corrusion. but after reaching home it didnt start then i notice is throwing lot of gas thru pto carb. That may mean the seat needle spring or screw came out so no pressure.

    BUt if i put the dual outlet with T will work as good?

  7. #7
    ryandi2's Avatar
    Join Date
    Aug 2009
    Location
    conesus ny!
    Posts
    2,092
    +1
    19
    x said you wouldbe ok to do it, so go ahead and do it...

    are you sure you put everything back together right?

    set all your carbs settings to factory if the pwc is stock, which i think it is.

    when you have it on the trailer and start it does it start reving by its self?

  8. #8

    Join Date
    May 2010
    Location
    Tampa, FL
    Posts
    127
    I know 95% is the needle seat maybe the spring came off. i have not had the time to check it. but i think is that. where can i get the T's? for the fuel pump?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. please help! Thanks with fuel pump
    By mrjetskey in forum 4-Tec Performance
    Replies: 2
    Last Post: 08-03-2012, 05:18 PM
  2. Polaris SL650 Help With The Fuel Pump Needed Please!
    By vicbomb5 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 06-13-2010, 08:23 AM
  3. 2001 GP1200R - HELP Please! Carb, Throttle Pump and More!!!
    By SoundXplosion in forum Yamaha PWC Performance (2-stroke)
    Replies: 26
    Last Post: 09-22-2009, 09:53 PM
  4. 2001 GP1200R - HELP Please! Carb, Throttle Pump and More!!!
    By SoundXplosion in forum Yamaha How To & FAQs
    Replies: 0
    Last Post: 09-14-2009, 03:24 PM
  5. Wrong fuel pump check valves?
    By kingstretch in forum Yamaha Old School Skis
    Replies: 18
    Last Post: 09-15-2008, 11:48 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •