Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1

    BIG problem after riding today HELP !

    Went out for a ride today in sunny south beach. rode around for a couple hours everything was great. On the way in I was about 60-70% on the throttle and all of a sudden the ski slows down drastically and doesn't let me accelerate. the check engine light came on. When I attempted to accelerate past that it would sound like it's misfiring or skipping. I was able to make it in. At the dock I pulled out some seaweed but nothing major.
    When I got home I flushed the ski out but the check engine light didn't come back on. I was able to give it a couple revs to about 6 grand and everything seemed fine. Anyone have any idea as to what might be wrong ????
    I got an 05 rxt


  2. #2
    Ever had the oem sc washers replaced?

  3. #3
    Banned User
    Join Date
    Aug 2009
    Location
    Discovery Bay, CA
    Posts
    3,048
    +1
    336
    doesnt have to be major seaweed to prevent enough water from flowing through the exhaust. maybe it was just overheating the exhaust a bit and thats the alarm you got

  4. #4
    I've never changed the washers but it doesn't seem like they are the problem...atleast compared to the other stories i've read.
    The overheating could be possible, the only thing is that on my inlaws ski when he was overheating the lcd said TEMP....I don't know if mine is different because it's an 05

  5. #5
    One quick...inexpensive way to find out that your oem washers are still intact.

    With the motor off, pull that rubber boot from your sc's intake and try to spin the blades.

  6. #6
    YoYamma's Avatar
    Join Date
    Aug 2006
    Location
    Central Florida
    Posts
    21,591
    +1
    4,798
    Quote Originally Posted by GreenMonster View Post
    I've never changed the washers but it doesn't seem like they are the problem...atleast compared to the other stories i've read.
    Dude, listen up. I would very cautious about starting that ski up again. Actually a big drop in RPM's is a classic sign of possible supercharger trouble, and the truth is; with those ceramics in there you are sitting on a time bomb; read this and get some metal washers and have someone check out your SC and engine before riding again:
    http://www.greenhulk.net/forums/showthread.php?t=19887

  7. #7
    Banned User
    Join Date
    Aug 2009
    Location
    Discovery Bay, CA
    Posts
    3,048
    +1
    336
    Quote Originally Posted by YoYamma View Post
    Dude, listen up. I would very cautious about starting that ski up again. Actually a big drop in RPM's is a classic sign of possible supercharger trouble, and the truth is; with those ceramics in there you are sitting on a time bomb; read this and get some metal washers and have someone check out your SC and engine before riding again:
    http://www.greenhulk.net/forums/showthread.php?t=19887
    +1 i didnt thnk u still had the time bombs in there....

  8. #8
    Work Harder, Millions on Wellfare Depend On Us! ultramaxracing05's Avatar
    Join Date
    Aug 2009
    Location
    Beaumont, Texas
    Posts
    2,999
    +1
    123
    read this thread. ppl with 5 to 80 hours on the engine had supercharger failure due to the ceramic washers, dont take a chance,
    http://greenhulk.net/forums/showthread.php?t=40298

  9. #9
    damn...ok so then the first step to check to see if the time bomb blew up is to take my intake hose off and see if the super charger wheel spins freely correct.
    Now if it doesn't spin freely can the washers still be blown to sh*t. ???

  10. #10
    if they are ceramic i would replace them regardless.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Problem during ride today.... Electrical expertise needed!
    By OBXJeepGuy in forum Yamaha Old School Skis
    Replies: 17
    Last Post: 08-15-2010, 05:16 PM
  2. Having problems starting my 900 STX after carb cleaning, HELP PLEASE???
    By Bala in forum Kawasaki PWC Performance (2-stroke)
    Replies: 1
    Last Post: 05-10-2008, 06:03 PM
  3. Big Problems!! Please Help!!!!
    By Inkaddict in forum Yamaha PWC Performance (2-stroke)
    Replies: 68
    Last Post: 04-04-2008, 09:57 AM
  4. Big Problem At The Lake Today (boom)
    By MIARider in forum 4-Tec Performance
    Replies: 87
    Last Post: 03-16-2008, 11:27 AM
  5. Impressions after First Ride today
    By 1 FAST VE in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-27-2005, 03:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •