Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1
    Jean-Paul's Avatar
    Join Date
    Jan 2010
    Location
    Greece, Athens
    Posts
    211

    Problem with exhaust hose. please help.

    hi guys.,

    yesterday the exhaust hose that connects the j-pipe with the waterbox came a little out having as a result one of the clamps to go higher as well and cutting my hose and spraying water all over. all the clamps were very tight and I cannot understand how is it possible for this hose to slowly coming outwards since the clamps were so tight. thankfully after tricks and hard pushing the ski i always check what is going on in the hull. it destroyed the rest of my day though.

    I will find a new hose, but my questions is should I use something else before putting the hose ? perhaps some silicone with heat resistance ??? or what ? in order to prevent this from happening again ? thanx in advance


  2. #2
    Banned User
    Join Date
    Aug 2009
    Location
    Discovery Bay, CA
    Posts
    3,048
    +1
    336
    seems like you've had a bunch of bad luck w/ that ski my friend!! hope you get it all sorted out

  3. #3
    Jean-Paul's Avatar
    Join Date
    Jan 2010
    Location
    Greece, Athens
    Posts
    211
    yeap !exactly !!! reminder to self : never buy a used ski again

  4. #4
    Work Harder, Millions on Wellfare Depend On Us! ultramaxracing05's Avatar
    Join Date
    Aug 2009
    Location
    Beaumont, Texas
    Posts
    2,999
    +1
    123
    maybe some T bolt clamps. I know worm clamps are not enough for the parts on the 4tecs

  5. #5
    Jean-Paul's Avatar
    Join Date
    Jan 2010
    Location
    Greece, Athens
    Posts
    211
    when you want to remove those they get destroyed though, right ?

  6. #6
    Work Harder, Millions on Wellfare Depend On Us! ultramaxracing05's Avatar
    Join Date
    Aug 2009
    Location
    Beaumont, Texas
    Posts
    2,999
    +1
    123
    your are talking about the Crimp clamps, aka Ozitikier clamps..yes they suck,

    i'm talking about T bolt clamps,
    I had worm clamps break on me, and moest of the time when tightened much they dig into the hose,

  7. #7
    Jean-Paul's Avatar
    Join Date
    Jan 2010
    Location
    Greece, Athens
    Posts
    211
    can you post a picture perhaps ? sorry for my ignorance..

  8. #8
    Banned User
    Join Date
    Aug 2009
    Location
    Discovery Bay, CA
    Posts
    3,048
    +1
    336
    http://www.amazon.com/1-38-Stainless.../dp/B002VQY7LO

    may not be the right size but thats basically a t-bolt clamp. make sure you buy stainless!

  9. #9

    Join Date
    Jun 2010
    Location
    Olathe, Kansas
    Posts
    37

    T-Bolt

    There right go with T-bolt clamps. I belive the manual also says to put high heat silcone on the ridges of the j pipe before clamping the rubber hose to it.

    I get my t-bolt clamps and silcone couplers from www.silconeintakes.com
    Good price and good servive.

  10. #10
    Jean-Paul's Avatar
    Join Date
    Jan 2010
    Location
    Greece, Athens
    Posts
    211

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Hi i think i have a problem with my gph please help need advice
    By liljosemiami in forum Kawasaki PWC Performance (4-stroke)
    Replies: 39
    Last Post: 10-14-2012, 05:38 PM
  2. new to this forum but have some problems with my js440 please help
    By dirtydave916 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 3
    Last Post: 06-16-2011, 01:15 PM
  3. Problem with 2003 GP1300R Please help
    By amf133 in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 03-27-2010, 02:51 AM
  4. Crazy Problem with RXPX display..Please Help?
    By RXTJeff in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 07-03-2008, 09:38 PM
  5. Problems with my 2006 RXT - help please !!!
    By BlackJack1 in forum 4-Tec Performance
    Replies: 20
    Last Post: 06-21-2007, 03:39 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •