Results 1 to 4 of 4
  1. #1
    SJ-(KY)'s Avatar
    Join Date
    Jul 2007
    Location
    Forest Hills,KY
    Posts
    278
    +1
    4

    MPEM Question for 98GSXL

    Is the MPEM from a 1998 GSXL(951) the same unit for of any of the Carborated 951 XP's? Gotta friend im trying to help out... He was goin down the lake an the ski just died... Now theres no power goin to the dash controls etc..etc.. Checked all the grounds Battery has power... Any of you guys had this problem? Tried swaping the MPEM out of a 99 XP an no luck ....


  2. #2
    KrunchovXPL-GTX-RX's Avatar
    Join Date
    Mar 2009
    Location
    Aiken, SC
    Posts
    1,391
    +1
    1
    The '98 XPL MPEM only had two plugs but it appears the GSXL had three like all the others. Still, the '98s only had one coil where the '99+ had two.

    Thus, that '99 MPEM would not work (in fact, one can but hope that it was not damaged by being connected to the wrong machine).

    It would seem that the '98 GSXL MPEM is unique.

    Did you check the main ground? It is under the starter and not the easiest to see so it can be overlooked.

  3. #3

    Join Date
    Apr 2005
    Location
    Eureka, MO
    Posts
    404
    +1
    1
    Yes, the 98 GSX-L & GTX-L had a three plug MPEM. It was sold under part numbers 278001343 and then 278001790. Should have a sticker on it that says 071000-1330 Denso. As Krunch said the 99 XP-L MPEM will not work on the 98 GSX-L.

    Check your fuses also.

    If you end up needing a new MPEM check with Jim Budnick at msavanaha(AT) aol.com. He may have one that he will sell.

    Dan (DRB)


  4. #4
    SJ-(KY)'s Avatar
    Join Date
    Jul 2007
    Location
    Forest Hills,KY
    Posts
    278
    +1
    4
    Thanks a bunch guys I appreciate it... You guys wouldent happen to know where i could find a 951 long block for sale would you?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 787 Mpem question for the gurus out there
    By RxBlaster in forum 2-Stroke Performance
    Replies: 15
    Last Post: 06-29-2017, 10:28 AM
  2. Tachometer for 96 XP - MPEM question
    By revhardSPX in forum 2-Stroke Performance
    Replies: 2
    Last Post: 08-08-2010, 07:22 PM
  3. Question for the resident computer gurus.
    By BertInTexas in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 06-14-2005, 04:24 AM
  4. Question for Jerry..
    By Therock in forum 4-Tec Performance
    Replies: 9
    Last Post: 05-25-2005, 05:11 PM
  5. Question for the Hulk
    By Therock in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-20-2005, 07:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •