Results 1 to 5 of 5
  1. #1
    stuckmoto's Avatar
    Join Date
    Jun 2010
    Location
    Newark, De
    Posts
    1,485
    +1
    59

    ECM update 06/18/10

    Hey guys, I just bought my RXT-X last week. Took it out for the first run and within 5 minutes the "maintenance required" light came on.
    So I called the dealer Saturday morning, the mechanic said a new update for the ECM just came out Friday. He said that I could bring it in and he would check the light and flash it. He wasn't exactly sure the details of the update.
    Anyone know?


  2. #2
    stuckmoto's Avatar
    Join Date
    Jun 2010
    Location
    Newark, De
    Posts
    1,485
    +1
    59
    Anyone have an idea?

  3. #3
    JT jpt7779's Avatar
    Join Date
    Jul 2008
    Location
    Pittsburg, Texas Lake Bob Sandlin
    Posts
    3,851
    +1
    742

    Talking Dealer Buffoonery!!

    Quote Originally Posted by stuckmoto View Post
    Hey guys, I just bought my RXT-X last week. Took it out for the first run and within 5 minutes the "maintenance required" light came on.
    So I called the dealer Saturday morning, the mechanic said a new update for the ECM just came out Friday. He said that I could bring it in and he would check the light and flash it. He wasn't exactly sure the details of the update.
    Anyone know?

    I think he may be blowing smoke! Several of us on this forum have had the same issue right from the start. The dealer is "SUPPOSED" to hook up BUDS to your brand new ski and reset/start the "Maintenence Required" timer. Several dealers have NOT performed this simple function prior to giving the ski to the customer. It is NO big deal at all, just a hassle to go back to the dealer.

    I just had my 10 hour "reset" done Friday morning at 13 hours and talked to the tech while we had BUDS hook up to my ski's. We discussed this very topic, no ECM update was done.

    Your gonna love this ski!

  4. #4
    Quote Originally Posted by jpt7779 View Post


    I just had my 10 hour "reset" done Friday morning at 13 hours !
    Excuse me for asking but does the ski need to be cleared by the dealer every time routine work is needed? I want to do all my own oil changes and routine Maintenance just because I hate going to dealers. This is going to be a pain if I have to have them reset it constantly.

  5. #5
    JT jpt7779's Avatar
    Join Date
    Jul 2008
    Location
    Pittsburg, Texas Lake Bob Sandlin
    Posts
    3,851
    +1
    742
    Quote Originally Posted by Alvin View Post
    Excuse me for asking but does the ski need to be cleared by the dealer every time routine work is needed? I want to do all my own oil changes and routine Maintenance just because I hate going to dealers. This is going to be a pain if I have to have them reset it constantly.
    Alvin no excuse needed!!!! The answer is NO, but anytime you get a "Maintenance Required" light, a dealer with BUDS has to reset it. i.e initial 10 hour and 100 hour supercharger reset.

    I agree with you, I do all my own maintenance also that I can. I have a great dealer in Fort Worth and know the staff very well. I changed my own plugs and oil, and did my own inspections and they did the 10 hour reset on my X260 and 100 reset on my GTX for $0.00!!! It only takes 5 minutes.......

    Have a good relationship with the dealer and you can do just about what you want!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Weekend update 5/5/10
    By w/rpm500 in forum Yamaha Old School Skis
    Replies: 12
    Last Post: 05-09-2010, 09:40 PM
  2. Restarting WEEKEND UPDATE!!.. 4/26/10
    By w/rpm500 in forum Yamaha Old School Skis
    Replies: 19
    Last Post: 05-01-2010, 11:44 PM
  3. Weekend Update 01/01/10
    By w/rpm500 in forum Yamaha Old School Skis
    Replies: 18
    Last Post: 01-08-2010, 05:19 PM
  4. Weekend update 12 /18 09!!
    By w/rpm500 in forum Yamaha Old School Skis
    Replies: 22
    Last Post: 12-23-2009, 05:02 PM
  5. 06 rxp 10 hour service
    By rxp127 in forum 4-Tec Performance
    Replies: 2
    Last Post: 05-05-2008, 09:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •