Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1

    99 Ultra 150 fuel system problems

    I have recently bought a reman motor from sbt. The motor installation went fine. Actually got the ski on the water and began break in. All was going well until the Ultra bogged and then died. After pulling the ski back to shore we confirmed that the ski was not getting fuel. We switch to the RES fuel setting and the ski ran for a short time and died again. When the motor was running it ran fine and came up to half throttle with no problem. Since bringing the ski home I have gone through the fuel system to determine what is wrong. I cleaned the tank filter and confirmed the fuel lines were clear and that the fuel petcock was working properly. The ski would intermittently start and get fuel flowing. The fuel was visible through the fuel filter. But is also stopped pumping fuel and died and wouldn't start again. I think it is the fuel pump. I was able to get the ski running using a siphon drawing from gas can but the ski's fuel system won't work consistenly. Is there anything else I can check that would cause the system to only work intermittently? Will the fuel pump on an ultra work intermittenly before it goes out? Is there any way to test the fuel pump? Any help would be appreciated. I don't like just throwing parts at a problem until I find the answer.


  2. #2
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,530
    +1
    1,281

    check the pulse line first

    then pressureize the tank via the fuel draw line (plug the return line) should hold 2-3 psi for at least ten minutes.

    Sounds like you have an air leak. The fuel pump can't draw enough fuel if air is leaking into the line. The pump is a bit pricey and there seems to be no rebuild kit available for it(talk about stuff that sucks)

  3. #3

    Checked the pulse line.

    Actually replaced it. Checked all lines. A leak wouldn't explain why it would not work and then start working. Best price I could find on pump was about $120(this sucks...). The pump would pull from a gas can through a siphon line but not through a straight line from the tank. Good thought though.

  4. #4
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,530
    +1
    1,281

    hmmmmm

    Quote Originally Posted by hel-bent View Post
    The pump would pull from a gas can through a siphon line but not through a straight line from the tank. Good thought though.
    you might have dropped the pickup tube in the tank if you can pull fuel from a gas can. With the cap off, blow into the fuel supply line, you should feel the fuel bubbling at the other end..if it's straight air..there's your problem.

    air leaks are strange to deal with..a small one can be hard to find and once the fuel manages to reach it, you might be able to pull enough to run the ski, even though air bubbles will be leaking into the line.. You need to pressure test the system..as you certainly don't want to be pulling the fuel pickups and tank on a guess.

  5. #5
    Blew air through the fuel line and heard bubbling in the tank. Blew through the return line and flowed through freely.

  6. #6

    I think its the fuel pump.

    Pressurized tank and it held pressure for 10 minutes.

  7. #7
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,530
    +1
    1,281

    more strange tales

    this one may get it's own chapter.....

    everything seems to be in order, yet the fuel pump won't pull from the tank, yet it can pull from a can.

    next question.

    when you were pulling from the can, was the can:

    a-on the ground
    b-sitting on the back of the ski
    c-higher then the ski

    if b or c I'd say the fuel pump isn't up to snuff or the pulse line is leaking. The pulse line should be huffing and chuffing a significant amount of air and stiff enough not to collapse.

    Now seeing it's a reman motor and we all know ( well we've read reports alleging) that sbt builders has made some pretty bonehead mistakes in the past might be possible that the crank seal between #3 and the counterbalance chamber isn't in right and negating the pulse effect to run the fuel pump. from your description of the failure mode, that's a possibility I would not be ignoring ( as totally painful as the end result is going to be)

  8. #8

    Final Chapter?

    The gas can was setting on the ski gunhal. New fuel pump is on the way. The only question I would have about the misinstalled gasket is would the ski still have run well initially? Thanks for your insight.

  9. #9
    DB Kustomz Zxspyderz's Avatar
    Join Date
    Jun 2008
    Location
    Eustis, Fl
    Posts
    83
    +1
    2
    Check the tanks vent line check valve. Mine went bad about a month ago cause a similar issue. Should go up toward the steering as a vent line. remove the valve and blow through it both ways it should only blow one way which goes from atomsphere to tank. Tank to atmosphere is should shut. If the valve fails like in my situation it wouldnt blow through either direction.

  10. #10
    Tank vent checked out prior to installing new fuel pump. The new fuel pump cured my problems.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Fuel/Choke Knobs interchangable for 99' Ultra 150 to 00' Ultra 150
    By Meen95z in forum Kawasaki PWC Performance (2-stroke)
    Replies: 6
    Last Post: 08-20-2015, 07:43 AM
  2. 2000 ultra 150 charging system problem
    By big john in forum Kawasaki PWC Performance (2-stroke)
    Replies: 1
    Last Post: 10-08-2012, 04:28 AM
  3. Ultra 150 fuel problem?
    By xxpaul17xx in forum Kawasaki PWC Performance (2-stroke)
    Replies: 2
    Last Post: 06-12-2012, 09:27 AM
  4. Need help please -- 99 ultra 150 problem
    By turbocycle in forum Kawasaki PWC Performance (2-stroke)
    Replies: 3
    Last Post: 10-17-2010, 07:19 PM
  5. 99 Ultra 150 an weird problems
    By xplayer2885 in forum Kawasaki How To & FAQs
    Replies: 8
    Last Post: 09-21-2006, 03:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •