Results 1 to 2 of 2
  1. #1
    Eastside Powersports Slow 91's Avatar
    Join Date
    Sep 2008
    River Crew CT

    97 XP Starting issue

    A friend of mine has a 97XP. Took it out for the first time this year and its got a starting problem. Gets the 2 beeps, hit the start button and it cranks over for about 1-3 seconds then no start. Every once in a while it will crank normal then fire. Does this sound like a bad starter? battery is good and fully charged.

  2. #2
    4.0l sahara's Avatar
    Join Date
    Jul 2009
    shelton ct
    check grounds.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Wave Blaster hard starting, voltage issue
    By Sam@Coastal in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 09-27-2007, 07:41 PM
  2. Not Starting!
    By jsc7002 in forum Yamaha Old School Skis
    Replies: 13
    Last Post: 08-30-2007, 09:35 AM
  3. 95 SLT750 Starting issue
    By rfriedman20 in forum Polaris Open Discussion
    Replies: 11
    Last Post: 08-11-2007, 12:24 AM
  4. 97 XP Starting issue
    By djdeet in forum 2-Stroke Performance
    Replies: 13
    Last Post: 08-09-2007, 11:04 AM
  5. Starting issue or not?
    By GPR FL in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 05-01-2006, 04:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts