Results 1 to 6 of 6
  1. #1

    polaris bogging down

    my 2001 polar-is virage tx jet ski is bogging down after it warms up. Top end is hesitant at best and it stalls if I try get out of the hole by nailing the throttle. If I gradually move the throttle up it will eventually (5-10 seconds) get out of the hole. Also, if I turn off the engine and let it sit for 30+ seconds, it takes a lot of time to get it to restart, and then it's another 10 seconds to idle correctly. I replaced the TPS last summer and it seemed to help albeit at that time it was more about top end, no problem getting out of hole. Could it be the TPS again or something else?


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,591
    +1
    1,275
    You have a fuel injected 2001 Virage TXi - correct?

    Are you seeing a red lamp or Check Engine message on the MFI display?

    It could be the TPS.
    Easy test - when it doesn't want to start, unplug the TPS connector. If it starts right away, then the TPS has a problem.

    Make sure the 3-pin TPS connector metal contacts are clean, no dielectric grease, and are gripping the mating pins tightly.

    If it is not the TPS, then is sounds like the 45 volt power system is weak. Have a look at this thread for some diagnostics you can do.

    2003 Polaris Genesis i 1200 starting issue

  3. #3
    Yes, it's fitch fuel injected. I'll try that next time. I did still have the old TPS, and I stuck it on there and it started right up but revved around 4500 RPM. Then took the current TPS and stuck it on and it took for ever to start. Would these be the culprit of the other issues?

  4. #4
    Also, no engine lights or codes.

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,591
    +1
    1,275
    Quote Originally Posted by frewworld View Post
    ...I did still have the old TPS, and I stuck it on there and it started right up but revved around 4500 RPM. Then took the current TPS and stuck it on and it took for ever to start...
    Will it start with no TPS connected?

  6. #6
    Yes it starts with no TPS.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1998 Polaris slth bogging down need help!
    By jb30 in forum Polaris PWC Performance
    Replies: 8
    Last Post: 10-29-2010, 02:49 AM
  2. polaris sl650 bogs down HELP!!!!!!!!!!!
    By allyfonzo in forum Polaris Open Discussion
    Replies: 0
    Last Post: 08-23-2010, 03:05 PM
  3. 1996 Polaris SL700 Bogging down/ Cutting Out
    By Hoepfl Hopper in forum Polaris Open Discussion
    Replies: 0
    Last Post: 07-19-2010, 10:58 PM
  4. 2001 Polaris Virage TX Bogs Down at 2000-3000rpm
    By frewworld in forum Polaris Open Discussion
    Replies: 7
    Last Post: 07-30-2009, 09:37 PM
  5. Polaris SL 750 bogging down
    By tom oswald in forum Polaris Open Discussion
    Replies: 4
    Last Post: 07-28-2009, 10:28 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •