Results 1 to 6 of 6
  1. #1
    WBoulton's Avatar
    Join Date
    Mar 2010
    Location
    doylestown PA, sea isle city, nj
    Posts
    569
    +1
    1

    fire extinguisher set ups on X4 hull

    where are you guys mounting them?? I always leave mine sitting in the hood compartment. well after being in the ocean this weekend mine put a hole in the box and went down in the hull next to my engine. trying to figure out a new set up.
    any help would be great thanks
    Bill


  2. #2
    Too many toys, not enough time snoopy'sbitch's Avatar
    Join Date
    May 2008
    Location
    Flanders NJ
    Posts
    124
    Isn't it supposed to be in one of the purple cylinder things in the front compartment? Thats where mine is

  3. #3
    WBoulton's Avatar
    Join Date
    Mar 2010
    Location
    doylestown PA, sea isle city, nj
    Posts
    569
    +1
    1
    I just found out they have ones that fit in there. I couldn't find one that fit at the boat place up the street from me. guess I gotta go back to the dealer.

  4. #4
    walmart sells them

  5. #5
    been around the block Stagesrt4's Avatar
    Join Date
    Mar 2010
    Location
    S. elgin
    Posts
    395
    yea get one of the small guys...it fits like a glove in purple cyl...


    you want it easily accessable...

  6. #6
    WBoulton's Avatar
    Join Date
    Mar 2010
    Location
    doylestown PA, sea isle city, nj
    Posts
    569
    +1
    1
    Quote Originally Posted by Wire4Money View Post
    walmart sells them
    I'll go check that out thanks!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Pro extended pump set up on a SL or SLX
    By Polaris_Nut#1 in forum Polaris PWC Performance
    Replies: 15
    Last Post: 06-23-2011, 09:58 PM
  2. What location are people installing bilge pumps on X4 hulls?
    By caliburst in forum 2-Stroke Performance
    Replies: 26
    Last Post: 06-11-2009, 09:18 AM
  3. Dual exhaust set up on slt750
    By xplayer2885 in forum Polaris Open Discussion
    Replies: 16
    Last Post: 02-19-2009, 11:19 AM
  4. SX-R 800 Set up on the MIKUNI 46
    By theone1 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 0
    Last Post: 02-22-2008, 03:52 PM
  5. Correct PV set up on 1200R
    By AndyW in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 10-03-2007, 02:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •