Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 25
  1. #1

    only turnig 7300 rpms.. im lost

    this is a challenger 180 jet boat with the 215.... its got an x charger, 42lb injectors, riva rrfpr, 4in cold air,external cooler ..
    charger slips at 117 in lbs, compression is good, new plugs, tried stock prop, 14/19 4 blade, 13/18 3 blade, replaced knock sensor, swapped throttle body with new one, no matter what, its a turd out the hole and only turns 7200-7400, depending on prop, checked for boost leaks..set base pressure fron 55lbs up to 64lbs, same results, im waiting for a ecu to try next... but im running out of ideas, anyone?? replaced both fuel filters on the pump.. anyone ever have issues like this?
    thanks
    mike b


  2. #2
    also swapped out coil packs, and ran with hood open in case of exhaust leak... same results..

  3. #3
    rxpdean's Avatar
    Join Date
    Mar 2010
    Location
    UK isle of wight
    Posts
    6
    when i was having the same problem with my ski it was the knock sensor adaptor, here is a list i found of what its used on

    hope it helps
    Dean

    Quote Originally Posted by beerdart View Post
    After doing some digging and resistance checks on my 05 I found out that the update also affects 05 models. The engine harness part number 420664951 is used on.

    Where Used: [420664951 (Engine Wiring Harness Ass'Y)]
    Challenger 180 4-TEC SCIC, 2005
    Challenger 180 4-TEC TOWER, Edition 1, 2006--
    Challenger 180 4-TEC, Edition 1, 2006
    Challenger CS TOWER, Edition 1, 2006
    Challenger CS, Edition 1, 2006
    GTX 4-TEC, LTD SCIC, 2005
    RXP, 2004
    RXP, 2005
    RXT, 2005
    Sportster 4-TEC SCIC, 2005
    Sportster 4-TEC SCIC, Edition 1, 2006

  4. #4
    ill look into that too, thanks, but this one is an 07

  5. #5
    Joe Stang's Avatar
    Join Date
    Aug 2008
    Location
    Durham, CT
    Posts
    1,928
    +1
    61
    Im curious myself. My 09 rxp is only running 7300.

  6. #6
    TheElite0ne's Avatar
    Join Date
    Jan 2009
    Location
    Tampa, FL
    Posts
    383
    +1
    20
    how many hours do you have on the boat?

    I've been fighting low RPM for awhile now too...In the last 3 months i've gone from 8080rpm to 7500rpm. Its gotten quite a bit warmer but a 580rpm change is just to much to be weather related.

    I've changed out both fuel filters but that didn't change anything. I'm glad I changed them because after 102hrs on the clock they looked like crap and appeared to be completely clogged.

    I've been told to go to the dealer and have the buds reset the TPS. Might give that a shot.

  7. #7
    jekvall's Avatar
    Join Date
    Nov 2007
    Location
    Chillicothe, OH
    Posts
    353
    make 100% sure your hoses and clamps are not leaking air from the supercharger.

  8. #8
    Quote Originally Posted by TheElite0ne View Post
    how many hours do you have on the boat?

    I've been fighting low RPM for awhile now too...In the last 3 months i've gone from 8080rpm to 7500rpm. Its gotten quite a bit warmer but a 580rpm change is just to much to be weather related.

    I've changed out both fuel filters but that didn't change anything. I'm glad I changed them because after 102hrs on the clock they looked like crap and appeared to be completely clogged.

    I've been told to go to the dealer and have the buds reset the TPS. Might give that a shot.
    its only got 25 hours

  9. #9
    Quote Originally Posted by jekvall View Post
    make 100% sure your hoses and clamps are not leaking air from the supercharger.
    no boost leaks

  10. #10

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2004 RXP will only get 54 MPH at 7300 RPMs
    By kingknine in forum 4-Tec Performance
    Replies: 4
    Last Post: 07-16-2011, 08:17 AM
  2. Replies: 9
    Last Post: 08-08-2010, 01:40 PM
  3. strainer... im lost
    By pbrxp in forum 4-Tec Performance
    Replies: 5
    Last Post: 03-18-2008, 12:30 PM
  4. Only getting 6300 RPM's
    By BIGJV RXT in forum 4-Tec Performance
    Replies: 7
    Last Post: 12-29-2007, 11:29 AM
  5. RXP only turning 7500 rpm ????
    By joeschoonover74 in forum 4-Tec Performance
    Replies: 13
    Last Post: 04-29-2007, 07:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •