Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 24
  1. #1

    95 seadoo xp questions

    Hey guys. I'm new to the whole seadoo scene and just bought 2 95 xps. Both the trims dont work. I read on another website to hook 12 volts to the motor and the motor works fine. I took apart the MPEM and found a blown 10amp fuse. I read somewhere that the 7.5 is what I should be looking for. Is that located in the MPEM. I have no idea what to do when it comes to seadoos! Sorry for asking stupid questions but any help would be great! Thanks!


  2. #2
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    Quote Originally Posted by dp154 View Post
    Hey guys. I'm new to the whole seadoo scene and just bought 2 95 xps. Both the trims dont work. I read on another website to hook 12 volts to the motor and the motor works fine. I took apart the MPEM and found a blown 10amp fuse. I read somewhere that the 7.5 is what I should be looking for. Is that located in the MPEM. I have no idea what to do when it comes to seadoos! Sorry for asking stupid questions but any help would be great! Thanks!
    Welcome to GH!

    pull the trim motors...if they work on a battery its something else like the switch or in most cases its the housing that needs to be replaced. the 7.5A fuse is for the trim and the 10A is the gauges. usually a bad mulitgauge is the culprit....remember the search button is your friend. if you still cant find it post up. no question is to stupid. trust me, I still ask'em

  3. #3
    Thanks for the help! Do you know where the 7.5 fuse is located? when i hit the trim button it makes a clicking noise. I read somewhere that is the relay and that if the 7.5 fuse is blown it makes that noise. I've been searching for it but can't find it. Is it behind the trim motor in the black box? Thanks

    Danny

  4. #4
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    the 7.5 is in the front gray box. crack that open and you will see the fuse. as for the VTS housing, unfortunately there is nothing you can do about it. you have to buy a new one if its trashed.

  5. #5
    Is the grey box the MPEM? We opened that and thats where we found the blown 10 amp fuse. But I didnt see a 7.5

  6. #6
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    Quote Originally Posted by dp154 View Post
    Is the grey box the MPEM? We opened that and thats where we found the blown 10 amp fuse. But I didnt see a 7.5
    yes, gray box = mpem...the mpem is actually the rectangular black box with fuses in it in the gray box but all the same. Its been a while since ive had a 95...I could have sworn that there is a 7.5 in the gray box. is there a black box in the rear of the ski? if there is its in there...

  7. #7
    the only black box I see in the back is the one connected the the trim motor. I will check the grey box again and let you know! Thanks for all your help!

  8. #8
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    ok, no, thats not the one that im thinking of. everything you are looking for is in the gray box. the fuse is probly under a cover of sorts on the mpem. they are in like right next to each other

  9. #9
    so far I have found 3 fuses in the grey box. I found 2 10s and 1 15. 1 10 and the 15 were next to eachother and the other 10 was off to the side.

  10. #10
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    Quote Originally Posted by dp154 View Post
    so far I have found 3 fuses in the grey box. I found 2 10s and 1 15. 1 10 and the 15 were next to eachother and the other 10 was off to the side.
    at some point someone added a bigger fuse to try and not make the vts fuse pop. never do that btw. im not sure which one it is ...i think that is the one off to the side. was it blown btw? down load a manual out of the top of the 2 stroke page and it will help get you the right fuse amperage you need.

    the one 15A is the mpem fuse and the 10A is the gauges and the (should be7.5) is the VTS

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [IL] FS: 95' Seadoo XP & Karavan trailer
    By VetteTech81 in forum Sea Doo 4Tec Skis
    Replies: 1
    Last Post: 10-11-2008, 01:35 PM
  2. [IL] FS: 95' Seadoo XP & Karavan trailer
    By VetteTech81 in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 10-05-2008, 10:34 AM
  3. ^^^^parts Needed For 95 Seadoo Xp ( 720 ) ^^^^
    By MILLER PHASE 3 1050 in forum Sea Doo Classifieds
    Replies: 5
    Last Post: 07-31-2008, 01:19 AM
  4. FS, 95' Seadoo XP (Savannah GA till 5/10)
    By VetteTech81 in forum Sea Doo Classifieds
    Replies: 2
    Last Post: 05-09-2008, 07:18 AM
  5. '95 seadoo xp vts
    By jetcar123 in forum 2-Stroke Performance
    Replies: 6
    Last Post: 08-15-2007, 11:28 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •