Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13

Thread: AFR help

  1. #1

    AFR help

    I made several runs today trying to adjust the powershot to get to the recommended range for an AFR reading. Idle (greeen) was at 10.2, 4500-4600 RPMs (amber) was from 9.6 - 9.8, and WOT ~8100 RPMs (red) was at 10-10.2 all with R & Ds settings of 2,2, and 4.5 respectively. I adjusted both up and down but could not get in the golden range (12.1 -12.5), closest I could come was in the low 11s. That came after dialing it down on the powershot but I also lost a little on WOT for RPMs.

    I don't know what else to do to get in the recommended range and crank out ~8200 RPMs on top end.


  2. #2
    Boilerman Bill BPnta's Avatar
    Join Date
    Jun 2008
    Location
    Yulee, FL
    Posts
    887
    +1
    1
    Make sure the cal on the O2 sensor is good. It should read 20.9 in ambient air.

    It's recommended to run 11.8 at WOT.

  3. #3
    Gone in 3.0 seconds... RXPT400's Avatar
    Join Date
    Nov 2007
    Location
    USA
    Posts
    1,527
    also make sure that the engine is at operating temperature and not cold. Your numbers at idle are too rich, you should be running in the 12s or 13s at idle..

  4. #4
    I wanna go fast perk_1405's Avatar
    Join Date
    Nov 2009
    Location
    winnabow, nc
    Posts
    202
    Quote Originally Posted by RXPT400 View Post
    also make sure that the engine is at operating temperature and not cold. Your numbers at idle are too rich, you should be running in the 12s or 13s at idle..

    mine stock runs 10.4 at idle

  5. #5
    Live Fast wave15stx's Avatar
    Join Date
    May 2007
    Location
    new jersey
    Posts
    2,214
    +1
    32
    at idle i vary from 10.7.-11.4

  6. #6
    desperado's Avatar
    Join Date
    Aug 2007
    Location
    Montreal, Canada
    Posts
    453
    +1
    3
    There is no need to run any lower than 12.0 at idle when at operating temperature. Multiple tests done with MoTeC M400 shows 12.3 to 12.7 is the sweetspot for idling. Running idle below 12.0 AFR is a waste of fuel and increases the risk of plug fouling and idling above 13.7 AFR will not run as smooth with some occasional misfiring. Comments are for idle speed between 1,350 to 1,600 rpm.

    My $0.02

  7. #7
    Sorry guys, my internet was down.
    I checked my ambient air and it read 21.8 per the gauge but wondering if I should calibrate again?

    If it is correct, I'm wondering why I can't bring my readings up, should I be reducing the fuel with the powershot? If so, I had it set to a 1 and still could not get the readings to be in the 12s.

  8. #8
    hitman's Avatar
    Join Date
    Aug 2006
    Location
    Ft. Lauderdale, FL
    Posts
    4,328
    +1
    12
    Quote Originally Posted by desperado View Post
    There is no need to run any lower than 12.0 at idle when at operating temperature. Multiple tests done with MoTeC M400 shows 12.3 to 12.7 is the sweetspot for idling. Running idle below 12.0 AFR is a waste of fuel and increases the risk of plug fouling and idling above 13.7 AFR will not run as smooth with some occasional misfiring. Comments are for idle speed between 1,350 to 1,600 rpm.

    My $0.02
    There is no way for us stock ECU or reflashed guys to adjust idle AFRs. They run extremely rich at idle from the factory. Mid 10s to mid 11s.

  9. #9
    SHOBiz's Avatar
    Join Date
    Jul 2008
    Location
    Wylie, Texas
    Posts
    3,577
    Quote Originally Posted by hitman View Post
    There is no way for us stock ECU or reflashed guys to adjust idle AFRs. They run extremely rich at idle from the factory. Mid 10s to mid 11s.
    +1
    Dats ryat

  10. #10
    Addicted Member 5001craig's Avatar
    Join Date
    Jul 2007
    Location
    Northeast Indiana
    Posts
    2,924
    +1
    11
    I just got my Pet tach installed and with the R2 I was EXTREMELY lean (won't even post #'s but will say I took her straight to the lift). Fingered-out the Powershot tonight and with the Red settings at 7 I was 11.9-12.0 at WOT. Red 7.5 was a bit too rich at mid 10's. All other settings are as-is reflashed with R2.

    I think my idle is something like 12.5 or a bit lower. I don't idle much.

    I am amazed at the pull from 7K to 8400.

    Now I want a C5 or E1.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. need help tuning RR rrfpr with AFR
    By IM2FAST4U in forum 4-Tec Performance
    Replies: 219
    Last Post: 09-08-2011, 09:31 PM
  2. help with install of lc-1 innvoted afr
    By stevorxp007 in forum 4-Tec Performance
    Replies: 40
    Last Post: 07-02-2010, 09:04 AM
  3. Need help AFR INJECTORS # not adding up
    By BlackHawk in forum 4-Tec Performance
    Replies: 182
    Last Post: 12-01-2009, 11:21 PM
  4. AFR Help please!!!!!!!
    By mongo in forum 4-Tec Performance
    Replies: 41
    Last Post: 10-21-2009, 06:05 PM
  5. Boost and Afr problems need help !!!!!!!
    By Blue Thunder in forum 4-Tec Performance
    Replies: 105
    Last Post: 10-05-2009, 10:41 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •