Results 1 to 9 of 9
  1. #1

    Electrical fire?

    Hey guys, i have a polaris Sl750,,
    a very sad thing happened today, when i worked on it, i took of a hose of from the water outlet, coming from the cooling rail because i needed the specs on it.
    it dident spil any water, that could have ben a reason, but in the electric box a Little fire started all the wires coming from the box is now fried and mealted,?

    The starter motor works fine ? what the **** happened?

    Anyone tried something like that?


  2. #2
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Try something like what?

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Did the electrical box shell short to the battery terminals?

    Is the plastic cover for the battery missing?

  4. #4

    Bat cover.

    Yes the battery cover is missing beacause that last owner had mounted a bigger battery i ordered the cover a year ago, but found out that i woulden´t fit.

  5. #5
    Mine suffered same demize by prevoius owner,Box is alum. and shorts out across posts on batt. if cover or some kind of protection is not there. looks like you better start shopping for a stator . how bad was it? Nate

  6. #6
    bowsniper's Avatar
    Join Date
    Aug 2008
    Location
    macomb,michigan
    Posts
    5,896
    +1
    6
    I made one out of carboard, tape and a rubber plate for the top. i never used it.. works great for something in the mean time. if you need it, ill mail it to ya.. it has a 3/16 inch rubber piece made into it for protection.

    the slots are cut for the wires too. heres a pic of it.

    Sorry to hear you had a fire in there. that stinks..
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	100_1534.jpg 
Views:	29 
Size:	56.5 KB 
ID:	194828   Click image for larger version. 

Name:	100_1535.jpg 
Views:	36 
Size:	88.6 KB 
ID:	194829   Click image for larger version. 

Name:	100_1537.jpg 
Views:	29 
Size:	79.1 KB 
ID:	194830  

  7. #7
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Quote Originally Posted by Puerto-Rico View Post
    Yes the battery cover is missing because the last owner had mounted a bigger battery

    i ordered the cover a year ago, but found out that it wouldn't´t fit.
    Well, I suggest you buy the correct size battery.

    The cover is important, as you have discovered.

    It sounds like you need to repair or replace the electrical box wiring. In addition, the wiring bundle to the magneto stator at the front of the engine may have been burned.

    Depending on how much damage you have, it may be best to purchase an entire used wiring harness and electrical box from a similar model that has been parted out.

    In addition to the Classifieds on Greenhulk, you can try John Zigler.

    Polaris PWC Parts Sources

  8. #8

    ..

    i took the engine out today, to find out that the black wire burned all its way from the electric box to the stator, but its only the black wire. but all other wires a serious damaged

    Havent pulled the stator out jet, Is the rope trick okay to use or?

    is it just a wire replacement? if its even possible to solder new wires on to the stator?

    i have now read about many people who had tried the same thing but non electric exept the black wire is fried.

  9. #9
    Quote Originally Posted by Puerto-Rico View Post
    i took the engine out today, to find out that the black wire burned all its way from the electric box to the stator, but its only the black wire. but all other wires a serious damaged

    Havent pulled the stator out jet, Is the rope trick okay to use or? yes/ you'll need a puller 2

    is it just a wire replacement? if its even possible to solder new wires on to the stator? yes/maybe if your good with a ohm meter and are willing to pull engine a 2nd time if it does not work

    i have now read about many people who had tried the same thing but non electric exept the black wire is fried.
    ????? the black wire is your main ground coming out of cdi when box shorts out across posts it goes to ground it can find. Thats why its fried and it takes rest with it.I bought a new stator did not want to chance it for the$$$ and time it takes to pull engine again. Hoping my cdi and coils are ok. As K447 says you'd be better off to get a new stator (wiring comes with right to box) less to worry about I.M.O Nate

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. SLX 780 Electrical Fire.
    By mudslinger83 in forum Polaris Open Discussion
    Replies: 28
    Last Post: 08-31-2013, 09:06 AM
  2. polaris slt750 wont fire - electrical problem
    By mkulczyckyj in forum Polaris Open Discussion
    Replies: 1
    Last Post: 06-26-2009, 11:33 PM
  3. RXP and fire extinguisher
    By rx4pain in forum Sea Doo Open Discussion
    Replies: 23
    Last Post: 11-21-2008, 10:54 AM
  4. pwc electrical fire
    By Jermany04 in forum Polaris How To & FAQs
    Replies: 5
    Last Post: 10-03-2008, 09:27 PM
  5. Pics of my 2005 RXP on FIRE!
    By WildBill9000 in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 05-31-2005, 03:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •