Results 1 to 8 of 8
  1. #1

    2004 Genesis I Won't Run...

    I'm so frustrated. I bought this ski brand new in 2004. It has only 28.8 hours on it. This year on the first day out the ski wouldn't run up past 4000 RPM. I pulled the original plugs which were fouled, replaced them and took the ski back out. Same problem. Won't rev past 4K RPM. Starts and idles just fine. If you pin it from a dead stop it surges and tries to rev up but won't. I took the new plugs out and they were fouled after only 15 minutes of riding at 4K RPM. I took it to Leaders Marine in Kalamazoo, MI as they're the closest authorized Polaris PWC Service Center. They said there was a bad ground on coil #1. The tech made a small jumper with two ring terminals and a short piece of wire and installed this between coil #1 and the cylinder head, replaced the plugs and said it was good to go. $98.00 I took it out on the water and it ran great for one trip around the lake then it started surging/hesitating/limited RPM's again. I pulled the plugs and they were fouled. I took it back to Leaders Marine and they said that the regulator had fallen off of the fuel pump. They quoted me $616.00 to install a new pump. Thanks to the info on this site I removed the fuel pump and sure enough the regulator was in the bottom of the tank. I fixed the regulator with the info found here, replaced the plugs and took it back out today. The exact same problems. Starts and idles just fine. At full throttle the engine sputters between 4 and 4.5K RPM. Won't go more than 25 MPH. If I back off the throttle to approx 3/4 throttle it smooths out and will run to 5K RPM and approx 30 MPH but if you try to accelerate it surges and slows down. I haven't yanked the plugs out again but I'm just assuming they're fouled.

    I checked the intake grates, no blockages. No codes, no service engine light. I'm completely frustrated. I don't want to take it back to Leaders as I feel they've had 3 times to check it and still have yet to correctly diagnose the issue.

    Does anyone have any advice? I'd sure appreciate it. Maybe even a better Polaris dealer in the N. Indiana, SW Mich, Chicago area? I'd really like to get this fixed.

    Thanks in advance.

    Jeff


  2. #2

    Join Date
    Aug 2007
    Location
    Albany Mn.
    Posts
    31
    TPS

  3. #3
    I should add that it revs up to redline on the trailer hooked up with the hose. Just not in the water under load...

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,570
    +1
    1,272
    Quote Originally Posted by chubby5258 View Post
    TPS
    +1

    Replace the TPS.

    It may be something else, but until you try a known good TPS, we will be just guessing.

  5. #5
    Where can I buy a new TPS at? I've tried 3 different places and no one has stock or can get one.

    Thanks again.

    Jeff

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,570
    +1
    1,272
    Quote Originally Posted by JJL1968 View Post
    Where can I buy a new TPS at? I've tried 3 different places and no one has stock or can get one.

    Thanks again.

    Jeff
    All this info is not hard to find

    Polaris PWC Parts Sources

  7. #7
    I've now called 4 places and no one has it in stock... back ordered till the end of August they say.

    Called...

    Babbits
    PartsPitsStop
    Partsland
    Leaders Marine

    I tried Ebay and theres one used one that's being sold with an entire throttle body.

    I did a Google search for the part and have calls into 3 more places.

    Ugh.

  8. #8
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,570
    +1
    1,272
    Quote Originally Posted by JJL1968 View Post
    I've now called 4 places and no one has it in stock... back ordered till the end of August they say.

    Called...

    Babbits
    PartsPitsStop
    Partsland
    Leaders Marine

    I tried Ebay and there's one used one that's being sold with an entire throttle body.

    I did a Google search for the part and have calls into 3 more places.

    Ugh.
    You are looking for part number 2202740 - correct?Ficht TPS versions, sources

    Try calling Jay at Sharps Marine.

    Polaris PWC Parts Sources

    Have a look here;
    New to the boards... 2002 Virage i issues

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. '00 Polaris Genesis FFR won't run
    By Bilgerat in forum Polaris Open Discussion
    Replies: 9
    Last Post: 08-15-2016, 09:08 PM
  2. 2004 Polaris Virage I Starts intermittently but won't run
    By kabekona in forum Polaris Open Discussion
    Replies: 1
    Last Post: 06-10-2015, 11:46 AM
  3. Replies: 4
    Last Post: 05-31-2014, 10:35 PM
  4. 02 Genesis i won't run need help.
    By agentslinger in forum Polaris Open Discussion
    Replies: 4
    Last Post: 11-17-2007, 04:47 PM
  5. 05 Stage 3 Riva Won't Run
    By WannabeGoing80 in forum 4-Tec Performance
    Replies: 18
    Last Post: 04-30-2007, 12:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •