Results 1 to 9 of 9
  1. #1

    Join Date
    Jul 2009
    Location
    Ft. Lauderdale, FL.
    Posts
    9

    2005 RXT only 7500 rpms

    max rpms im getting is 7500. recently had supergharger by ppg and oil change done. what can cause this.


  2. #2
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    We have 2 threads going on this right now:

    http://www.greenhulk.net/forums/showthread.php?t=129655


    http://www.greenhulk.net/forums/showthread.php?t=126515


    Not saying these are any of your issues BUT you can read into them to see if anything weve done may help you out...When was the last time the Scer slip was checked and set??

  3. #3
    I had the same issue last year with my 06 RXT, riva stage II+ ride.... was running up to 8060 RPM and suddenly dropped down to 7600 - 7700 and couldnt get any more out of it. I checked everything, boost leak, wear ring, plugs, coil packs, vac leaks, blocked off the blow off valve.... nothing worked. I traded the ski a few weeks ago for a 2010 rxt-x. I am very curious to see what someone discovers.... sounds as if this is starting to be a common problem.

  4. #4
    Orlando Shark's Avatar
    Join Date
    Mar 2009
    Location
    Miami, FL
    Posts
    2,419
    +1
    10
    Quote Originally Posted by Meteor View Post
    I had the same issue last year with my 06 RXT, riva stage II+ ride.... was running up to 8060 RPM and suddenly dropped down to 7600 - 7700 and couldnt get any more out of it. I checked everything, boost leak, wear ring, plugs, coil packs, vac leaks, blocked off the blow off valve.... nothing worked. I traded the ski a few weeks ago for a 2010 rxt-x. I am very curious to see what someone discovers.... sounds as if this is starting to be a common problem.
    I don't see listed that you checked the slip. depending on the condition you ride in, superchargers will lose slip causing you to lose boost. I am sure that could be the problem both of you have and had. When was the last time you checked your slip?

  5. #5
    KC Blue Thunder's Avatar
    Join Date
    Oct 2007
    Location
    Jacksonville, Florida
    Posts
    2,079
    Same here.... Checked slip, changed plugs, Checked wear ring, and did a boost leak check.... no joy. Going back to the draw board with afrs.

  6. #6
    Had my S/C rebuilt last summer and slip was adjusted then.... i had the issue with RPM loss a month or so after that was done.

  7. #7
    Orlando Shark's Avatar
    Join Date
    Mar 2009
    Location
    Miami, FL
    Posts
    2,419
    +1
    10
    If the screw in the back of the supercharger which holds your clutch and washers toghether was not torqued properly or they never added loc tite then the screw could loosen up and cause you to slip. I would pull the supercharger and check to see if that was the issue and redo your slip while you are at it.

  8. #8
    Orlando Shark's Avatar
    Join Date
    Mar 2009
    Location
    Miami, FL
    Posts
    2,419
    +1
    10
    Quote Originally Posted by Blue Thunder View Post
    Same here.... Checked slip, changed plugs, Checked wear ring, and did a boost leak check.... no joy. Going back to the draw board with afrs.
    What year is your ski, if 2004, does it have the knock sensor piggy back? If not then what setup are you running?

  9. #9
    KC Blue Thunder's Avatar
    Join Date
    Oct 2007
    Location
    Jacksonville, Florida
    Posts
    2,079
    Quote Originally Posted by ImAShark View Post
    What year is your ski, if 2004, does it have the knock sensor piggy back? If not then what setup are you running?
    07 GTX, Mini Rude, 48's, Dual Reg setup, 15/22 untoched, XS I/C, 4" intake, TB mod and a couple of other goodies.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2008 RXT only reaching 7500 rpm
    By RobJ in forum 4-Tec Performance
    Replies: 16
    Last Post: 08-11-2016, 07:53 PM
  2. Only 7500 rpm on 2010 RXT-X 260 with no errors codes
    By not2fast in forum 4-Tec Performance
    Replies: 16
    Last Post: 08-03-2015, 08:14 PM
  3. Only 3000 rpm on my 2005 RXT
    By kaorder1999 in forum 4-Tec Performance
    Replies: 6
    Last Post: 05-08-2011, 08:38 AM
  4. 2005 RXT turning 8100 rpm
    By Kragar in forum 4-Tec Performance
    Replies: 4
    Last Post: 09-04-2007, 01:11 PM
  5. RXP only turning 7500 rpm ????
    By joeschoonover74 in forum 4-Tec Performance
    Replies: 13
    Last Post: 04-29-2007, 07:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •