Results 1 to 3 of 3
  1. #1

    Join Date
    Jun 2010
    GTA , Canada

    New GP760 Owner (with a couple questions)

    I just traded my sled for a 98 GP760 and I must say this thing is a blast to ride. This is my first PWC but not my first toy.

    The machine has some issues. Primarily it is lacking power/ accelleration. When I get past 3/4 throttle the machine has a wierd misfire, almost like a rev limit. but it comes in right around 6000 rpms and i cant get it to rev any higher.

    I've tried changing the plugs and I've had the carbs cleaned and re-adjusted to factory settings.

    I'm begining to wonder if the machine is just hitting factory rev limit, however I can only get it to run about 65 km/h on flat water at 6000 rpms.

    Thanks in advance for any input.


  2. #2
    1131 Adam E.'s Avatar
    Join Date
    Oct 2009
    Fort Bragg, NC
    The Rev limiter on your unit is 6350 RPM's. I wouldn't trust your stock tachometer though, it may be giving you skewed readings. You need an aftermarket PET 2100 (expensive, but the best) or Tiny Tach (cheaper) to get optimal readings.

    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	760.jpg 
Views:	65 
Size:	79.7 KB 
ID:	195082  

  3. #3

    Join Date
    Jun 2010
    GTA , Canada
    Thanks that's great info.

    Im assuming that a GP with a worn seal/ring around the impeller would bounce off the rev limiter like crazy and kinda go nowhere? THis machine seems to run great (even idles and revs nice) otherwise.

    Is there any way to tell when the limiter is active? I'm hoping to narrow this down to a pump/cavitation problem.


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. about to be new owner, couple questions...
    By badass989 in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 04-05-2008, 05:21 PM
  2. 98 Gp760 questions (oil smoke/runoff & impeller)
    By FlynHokie in forum Yamaha Old School Skis
    Replies: 26
    Last Post: 09-24-2007, 10:27 AM
  3. New Owner with questions
    By frbob in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 07-29-2007, 07:23 AM
  4. couple of questions
    By 05blastsrt4 in forum Kawasaki Open Discussion
    Replies: 1
    Last Post: 07-15-2007, 11:07 AM
  5. New '07 150 SCIC owner, couple of questions.
    By Armand28 in forum Sea Doo Sport Boats
    Replies: 3
    Last Post: 05-26-2007, 04:40 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts