Results 1 to 3 of 3
  1. #1

    Join Date
    Jun 2010
    Location
    GTA , Canada
    Posts
    54

    New GP760 Owner (with a couple questions)

    I just traded my sled for a 98 GP760 and I must say this thing is a blast to ride. This is my first PWC but not my first toy.

    The machine has some issues. Primarily it is lacking power/ accelleration. When I get past 3/4 throttle the machine has a wierd misfire, almost like a rev limit. but it comes in right around 6000 rpms and i cant get it to rev any higher.

    I've tried changing the plugs and I've had the carbs cleaned and re-adjusted to factory settings.

    I'm begining to wonder if the machine is just hitting factory rev limit, however I can only get it to run about 65 km/h on flat water at 6000 rpms.

    Thanks in advance for any input.

    Brandon


  2. #2
    1131 Adam E.'s Avatar
    Join Date
    Oct 2009
    Location
    Fort Bragg, NC
    Posts
    458
    +1
    3
    The Rev limiter on your unit is 6350 RPM's. I wouldn't trust your stock tachometer though, it may be giving you skewed readings. You need an aftermarket PET 2100 (expensive, but the best) or Tiny Tach (cheaper) to get optimal readings.

    Adam
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	760.jpg 
Views:	70 
Size:	79.7 KB 
ID:	195082  

  3. #3

    Join Date
    Jun 2010
    Location
    GTA , Canada
    Posts
    54
    Thanks that's great info.

    Im assuming that a GP with a worn seal/ring around the impeller would bounce off the rev limiter like crazy and kinda go nowhere? THis machine seems to run great (even idles and revs nice) otherwise.

    Is there any way to tell when the limiter is active? I'm hoping to narrow this down to a pump/cavitation problem.

    Thanks!
    Brandon

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New polaris owner with a few questions
    By Ladrhog in forum Polaris PWC Performance
    Replies: 9
    Last Post: 08-19-2016, 10:32 AM
  2. New guy with a couple questions ?
    By Wiskey Tango Foxtrot in forum Kawasaki How To & FAQs
    Replies: 0
    Last Post: 01-29-2016, 09:22 AM
  3. New fzr owner with mod question
    By mhagley in forum Yamaha PWC Performance (4-stroke)
    Replies: 10
    Last Post: 12-20-2013, 12:54 AM
  4. New Yamaha owner with couple questions
    By Mercpower in forum Yamaha Open Discussion
    Replies: 5
    Last Post: 02-04-2013, 07:10 AM
  5. New member/RXP owner with a few questions
    By ckybltz in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 07-17-2007, 10:10 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •