Results 1 to 7 of 7

Thread: desperate

  1. #1

    desperate

    I have a sea doo rxp 2005. I was riding seen the oil light come on and when i went into higher rpms it would bog down. so i added oil it didnt help. so i took the ski out of the water and did a oil change and spark plugs. when i took the old spark plugs out they where black and i just replaced them two weeks ago. so im letting it run with the wahout on it and i see oil and water mix coming out of the exhaust. so i shut it off and a cloud of smoke comes from the back. so i restart it and the same thing happens but the motor sounds like it allways did. what could be wrong???????????


  2. #2
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    What does the oil look like on the dipstick? Is it milky looking?

  3. #3
    Are you sure you put the correct spark plugs in two weeks ago when you changed them? Plugs should be NGK (4339) DCPR8E. Black plugs could be a sign of your plugs running cold, so you might have the wrong plugs or the gaps could be way off.

  4. #4
    The oil is not milky when I pull the dip stick

  5. #5
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    Where is the oil level on the dipstick? Should be between the 2 bends on the stick.

    check your intercooler for signs of oil or leaks. Check your compression.

    What mods have been done to it?

  6. #6
    The oil is fine how do I check compression

  7. #7
    ANASTY's Avatar
    Join Date
    Mar 2010
    Location
    High Rock Lake NC
    Posts
    28
    Quote Originally Posted by purpledrillmonkey View Post
    Are you sure you put the correct spark plugs in two weeks ago when you changed them? Plugs should be NGK (4339) DCPR8E. Black plugs could be a sign of your plugs running cold, so you might have the wrong plugs or the gaps could be way off.

    what do the gaps need to b?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB 1200 nonpv case or whole motor desperate!
    By farndogg7 in forum Yamaha Classifieds
    Replies: 24
    Last Post: 12-04-2008, 09:22 PM
  2. needed exciter 270 engine parts desperate
    By farndogg7 in forum Yamaha Classifieds
    Replies: 3
    Last Post: 11-05-2008, 06:45 PM
  3. WTB/Desperately Need 785 Exhaust Valve Motor
    By goBENGALS in forum Polaris Classifieds
    Replies: 4
    Last Post: 10-14-2008, 12:26 PM
  4. Replies: 8
    Last Post: 05-17-2008, 11:21 AM
  5. Coinsidence or my fault?? Opinions needed desperately
    By Fuhreal in forum Sea Doo Open Discussion
    Replies: 17
    Last Post: 07-03-2006, 08:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •