Results 1 to 2 of 2
  1. #1
    98gsxl951's Avatar
    Join Date
    Jul 2008
    Location
    On my ski, on the CT river
    Posts
    879
    +1
    3

    rx di runing crappy and sometimes fine.

    replaced voltage reg, ran like a champ for the last few rides, now it seems to be acting up again. sometimes it runs good, sometimes it will bog out and die when you give it gas. also maint light comes on once in a while , doesnt effect ski though and not sure why. checked all connections everything looks good to the eye. any ideas?


  2. #2
    olds72's Avatar
    Join Date
    Nov 2009
    Location
    Toledo, OH
    Posts
    173
    +1
    1
    How old is the battery? Make sure it's fully charged. The DI's and RFI's require a fully charged battery and properly operating charging system.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2001 RX Di missing and maint light on
    By jetmanjay in forum 2-Stroke Performance
    Replies: 3
    Last Post: 07-28-2011, 05:15 PM
  2. WTB 2003 Sea Doo RX-DI Speed sensor and Shock
    By JohnCiccarelli in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 01-19-2011, 11:35 AM
  3. FS 2000-2001 gtx/rx-di mpem and lanyard
    By brisyl in forum Sea Doo 2 Stroke Skis
    Replies: 3
    Last Post: 09-04-2010, 07:07 AM
  4. Replies: 0
    Last Post: 06-01-2010, 07:36 AM
  5. 01 rx di maintenance light and power is on and off...
    By 98gsxl951 in forum 2-Stroke Performance
    Replies: 5
    Last Post: 05-19-2010, 10:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •