Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
  1. #1

    battery not charging 05 rxp

    like title says battery has barely enuff juice to start and if i drive around for 5 mins it gets worse but if u drive for 10-15 it seems to help. I tested the system by disconnecting the negative terminal while running and it died right away which would mean its not the battery????????? what would cause this problem, any help very appreciated


  2. #2
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    These systems aren't like cars, I would check your fuses first. There are 2 fuses on the side of the MPEM in a separate housing that are 30A and run the charging system. Check if blown, or corroded.

  3. #3
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    If it seems to get better the more you ride it... I would question the condition of the battery itself Is it the original 05 battery

  4. #4

    Join Date
    Jul 2006
    Location
    Beaufort, SC
    Posts
    592
    i have to get a new battery every season. charging system is fine, oem batterys and riva batteries blow

  5. #5
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Quote Originally Posted by BoostedH23a1 View Post
    i have to get a new battery every season. charging system is fine, oem batterys and riva batteries blow
    I got 4 years out of my original battery... guess it comes down to how you maintain them

  6. #6
    freddyfcs's Avatar
    Join Date
    May 2010
    Location
    Queens,NY
    Posts
    45
    I had the same problem before..And i reconditioned my battery and so far so good

  7. #7
    if you keep them on a battery tender in off season they will last a long time. battery tender plus is what i have . i keep it hooked to my bike and now the ski as well. it was about $45 but beats buying new batteries every year

  8. #8

    Join Date
    Jul 2006
    Location
    Beaufort, SC
    Posts
    592
    yea i have a 1.5 amp on mine. if i dont have bad luck i wouldnt have any luck though. i keep tenders on the airplanes and they seem to do fine.

  9. #9
    the old owner said the battery was changed last year, ill check fuses tommorow, thanks for the help

  10. #10
    Work Harder, Millions on Wellfare Depend On Us! ultramaxracing05's Avatar
    Join Date
    Aug 2009
    Location
    Beaumont, Texas
    Posts
    2,999
    +1
    123
    just switch to AGM, i was dumping my money on BS batteries and keeping them on the tender and still didnt last long, I switched to AGM and the battery tender is collecting dust!

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 0
    Last Post: 06-06-2011, 01:08 AM
  2. battery not charging on R12X
    By gregdole7 in forum Honda Open Discussion
    Replies: 4
    Last Post: 08-07-2010, 07:20 PM
  3. Battery not charging
    By chopper400ex in forum Polaris Open Discussion
    Replies: 2
    Last Post: 07-15-2009, 10:00 AM
  4. Ultra 150 Battery not charging/battery light flashing
    By kcoleman10 in forum Kawasaki Open Discussion
    Replies: 5
    Last Post: 02-13-2009, 01:18 AM
  5. battery not charging on 1999 gsx
    By scott o in forum 2-Stroke Performance
    Replies: 1
    Last Post: 07-22-2007, 01:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •