Results 1 to 2 of 2
  1. #1
    YoCoLifSavr's Avatar
    Join Date
    May 2010
    Location
    East Coast, Virginia
    Posts
    74

    1994 Kawasaki TS Jet Ski Help!

    So I took my jet ski out today to take it for a test run and it started giving me problems. It is a 94 2 stroke 650. The jet ski wouldnt run over 10mph. The engine was performing ok and had plenty of power but when you hit the throttle it wouldnt go above 10mph. It just seemed like it wouldnt pump the water as tho it was cavitating. I did check the impeller and it was spinning though. Any suggestions, ideas? This thing should be hauling butt....


  2. #2
    YoCoLifSavr's Avatar
    Join Date
    May 2010
    Location
    East Coast, Virginia
    Posts
    74
    Problem has been fixed. I blew out all my cooling hoses and there were sea shells, oyster shells and rocks jammed up in them.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. how do i set a carburetor on a 1985 Kawasaki 440 jet ski?
    By jarro27 in forum Kawasaki How To & FAQs
    Replies: 0
    Last Post: 04-22-2012, 11:06 PM
  2. FS 94 Kawasaki X2 Jet Ski - Sebastian, FL
    By Pitstop504 in forum Kawasaki Skis
    Replies: 1
    Last Post: 11-19-2009, 01:33 PM
  3. 1985 Kawasaki 550 Jet Ski
    By killercatt in forum Open Discussion
    Replies: 1
    Last Post: 07-30-2009, 03:01 PM
  4. 1985 Kawasaki 550 Jet Ski
    By killercatt in forum Kawasaki PWC Performance (2-stroke)
    Replies: 0
    Last Post: 07-27-2009, 09:02 PM
  5. 1983 Kawasaki JS440 Jet Ski
    By ugadawg131 in forum Kawasaki Open Discussion
    Replies: 1
    Last Post: 12-23-2006, 06:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •