Results 1 to 4 of 4
  1. #1

    2001 Virage TXi Ficht won't idle, fuel slowly drips from injectors when removed

    So there I was, pulling my friend around on the tube on my Virage, when he hit a wake and went flying off the tube. HILARIOUS. when i turned around to pick him up, the ski died upon my letting go of the throttle. Didn't start back up. luckily a lifeguard saw us, and pulled us in.

    when i got the ski home, i started troubleshooting. we have good spark. i pulled each injector off, and the fuel was dripping out of them. i understand that is supposed to be a misty spray, not a drip coming from the injectors. could a clogged fuel filter, or collapsed fuel line or bad fuel pump be the problem?

    the ski will start if i hold the throttle while cranking, and will run with the throttle being played with, but will not idle.

    PLEASE HELP ASAP. my family is coming to visit in 2 weeks, and i would like them to enjoy Hawaii on the ski. Thanks.
    Last edited by K447; 05-11-2011 at 11:07 PM.


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,574
    +1
    1,272
    Welcome to the Hulk

    The injectors will not operate properly without being clamped into the cylinder head. Be careful when re-installing them. The injectors must be tightened up evenly, so they are not pulled to one side. Make sure the large rubber O-ring is in position on top of each injector.

    You need to check some things;
    Fuel pressure. When the engine is cranking, fuel pressure should be over 20PSI.

    TPS. Unplug the Throttle Position Sensor. It is located at the rear end of the throttle body assembly, tucked under the flame arrestor base. See if the engine will start AND idle with the 3-pin TPS connector unplugged. It will NOT respond to the throttle with the TPS unplugged.
    Last edited by K447; 05-11-2011 at 11:05 PM.

  3. #3
    Well i pulled the Tps connector off and it will not start up. The ski has 494 hrs on it. Which i know is high hours... What else can i do

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,574
    +1
    1,272
    Quote Originally Posted by 1_kwik_virage View Post
    Well i pulled the Tps connector off and it will not start up. The ski has 494 hrs on it. Which i know is high hours... What else can i do
    Check fuel pressure.

    Check injector voltage. White/Red wire should have over 20 volts while cranking. Do not unplug any injectors to measure the voltage.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2001 Virage TXI FICHT loud backfires when trying to start, will not start
    By terrygilomen in forum Polaris Open Discussion
    Replies: 11
    Last Post: 08-12-2016, 07:44 AM
  2. 2001 Virage TXi fuel injected - no warm restart
    By Elunicogaby in forum Polaris Open Discussion
    Replies: 2
    Last Post: 02-12-2013, 12:08 PM
  3. Polaris 2001 Virage TXI 1200 idles great will not go over idle
    By jsmiech in forum Polaris Open Discussion
    Replies: 5
    Last Post: 01-01-2012, 01:00 PM
  4. 2001 Virage TXI fast idle
    By looker_ford in forum Polaris Open Discussion
    Replies: 13
    Last Post: 04-21-2010, 08:26 AM
  5. 2001 Virage TXI Fuel Problem, I THINK???
    By axman19 in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 07-05-2008, 08:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •