Results 1 to 3 of 3
  1. #1

    Unhappy 2004 msx 150 black carbon plugs and limited rpm

    Msx 150 has spark plug problems I have replaced the plugs and put a new battery in it . The RPM are limited to 3500 ,its as if there no gas going to the engine . I have cleaned the sensors and the intercooler has been cleaned . There is no trouble codes displaying . there is fresh gas in the machine . can someone help me here Thanks Joe


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,575
    +1
    1,272
    Does the display say 'Reverse'?

  3. #3
    Kosh's Avatar
    Join Date
    Sep 2007
    Location
    Australia
    Posts
    1,483
    +1
    83
    History on this one? has it been running OK. Sounds like your turbo is not spinning. Quick check, remove the turbo to intercooler hose, at idle it will be a powerfull as a good hair dryer.

    Check the temp sender on the exhaust manifold as well.

    Cheers

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2004 MSX-150 Surges and MAX RPM 5850
    By rcsscraig in forum MSX/Matrix
    Replies: 37
    Last Post: 09-09-2015, 06:53 AM
  2. Replies: 16
    Last Post: 07-13-2013, 11:24 PM
  3. 2004 Msx 150 only goes 45 and has rough idle
    By william10cam in forum MSX/Matrix
    Replies: 3
    Last Post: 05-03-2012, 04:53 PM
  4. 2001 and 2004 MSX 150
    By loonatik in forum Polaris Projects
    Replies: 18
    Last Post: 03-29-2012, 04:47 PM
  5. 2004 MSX 150 problems
    By Rocky Balboa in forum Polaris Open Discussion
    Replies: 59
    Last Post: 02-08-2007, 11:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •