Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1

    Join Date
    Jan 2006
    Location
    perth australia
    Posts
    124

    motor filled with coolent..any help please....

    yesterday i took my 05 rxp out,,, after its 50 hr service i also had les's washers installed,my ceramics came out in pretty good condition but sum other washers were a bit bent out of shape.... 10 mins into my ride ski lost power and sounded awful thuddering noise,,, i limped back to shore.. coolent bottle is emppty no.3 spark plug is smashed up on the end all cylinders are full of coolent,,, motor still cranks,, so it isnt seized,,, it looks like no.3 piston and valves need replacing... it was first ride after storage for 6 months,,, i winterized it thoroughly...i ride salt water mainly...... any one had this happen.. how could coolent enter motor cylinders... i have one month of warranty left, i took it to dealer today, he's pulling the head off tomoro, any ideas????


  2. #2
    SHIFT's Avatar
    Join Date
    Sep 2006
    Location
    Sydney, Australia
    Posts
    178
    is it stock??

  3. #3

    Join Date
    Jan 2006
    Location
    perth australia
    Posts
    124
    all ive done is riva grate, solas prop, all done when purchased new...

  4. #4
    Tiburon's Avatar
    Join Date
    Aug 2006
    Location
    South FL
    Posts
    242
    For starters sounds like the head gasket went....... the rest they will find out when they pop the head off... hope its not to bad..

  5. #5

    Join Date
    Sep 2006
    Location
    down under
    Posts
    645
    +1
    15
    split a cylinder??

  6. #6
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Quote Originally Posted by tris View Post
    i also had les's washers installed,my ceramics came out in pretty good condition but sum other washers were a bit bent out of shape
    Those are Bellville washers (spring washers) and are supposed to be concave looking (bent out of shape looking)

    Forgive me for asking, but what are you calling the #3 piston... the piston all the way to the front or the rear? I know the very front piston is #3, but many people call the rear piston #3.

  7. #7
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    I saw you just posted this on another thread

    my valves just went in #1,, rear cylinder my ski has stock intake
    This reaffirms my suspicion. What i "think" happened is the supercharger was not reassembled properly. The nut came off the back which would in turn drop all the spring washers, gear, etc. These dropped down on the flywheel gear causing parts to force through the block into the rear (#1) cylinder causing the catastrophic failure.

    When you mentoined that some of the supercharger washers were bent out of shape (spring washers) it leads me to believe that maybe the person that worked on your supercharger replaced them with regular flat washers or maybe even hammered them flat in an attempt to "fix them"
    If something like this happened the nut on the back of the SC would surely come loose.

  8. #8
    Moderator The Bandit's Avatar
    Join Date
    Jul 2006
    Location
    Wilmette, IL
    Posts
    8,373
    Excellent diagnosis Dr. Hulk, I am impressed

  9. #9
    RustySeaRustyDoo's Avatar
    Join Date
    Oct 2005
    Location
    Chesapeake Bay-Pasadena, MD
    Posts
    1,788
    Jerry,

    Nice description. You def are the man. You could be making a lot of money with the knowledge you have!

  10. #10
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    You think so Rusty? Im open for ideas

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 10
    Last Post: 05-29-2017, 09:59 AM
  2. polaris sltx 1050 rebuilt motor or swap to 1200 help please
    By sltx1050 in forum Polaris Open Discussion
    Replies: 12
    Last Post: 03-17-2012, 07:02 AM
  3. Replies: 1
    Last Post: 05-13-2011, 03:22 PM
  4. how to fit solas any help please
    By rior1 in forum 4-Tec Performance
    Replies: 10
    Last Post: 02-07-2007, 04:40 PM
  5. Somethings wrong with my machine, help, please read!!!
    By NeverEndn in forum 4-Tec Performance
    Replies: 15
    Last Post: 08-11-2006, 09:57 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •