Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1
    Overcenter76's Avatar
    Join Date
    Aug 2009
    Location
    St. Cloud, Florida
    Posts
    18

    RXP Will Not Come Out the Hole

    I just did my first round of modifications to my 06 RXP. I installed a Solas 14/19 impeller , R&D Aquavein Grate and Riva OPAS eliminators. I also installed a new pump shoe and ware ring. The ski ran strong with 130 hours on it when I pulled it out of the water. The repairs and installation of the parts went smooth; however, after I took it out for a ride I was disappointed. The ski feels like a car with a slipping clutch, it will not come out of the hole and the top speed is down. I pulled the ski out and disassembled the jet pump, pulled the drive shaft out and double checked all of my work, and I see nothing obviously wrong. Any helpful pointers would be appreciated.

    Thanks,
    Kevin


  2. #2
    Hmm....did you do anything to your air intake?....if not....you're way over propped....especially after adding a grate.....what's a pump shoe?...why did you remove the drive shaft? How long ago did you "pull it outa the water"...before doing these mods? What rpms were you turning before and after the mods.


    Need alot more info.

  3. #3
    Overcenter76's Avatar
    Join Date
    Aug 2009
    Location
    St. Cloud, Florida
    Posts
    18
    I have yet to change the intake, it is in my plans. Would that really cause it to run like dog balls out of the hole, if so I will order an air intake tomorrow. The pump shoe or pump support is that big black hunk of plastic the jet pump and the intake grate mounts to. The ski has been out of the water for a month and a half. I only road the ski for 5 minites and did one high speed blast and I did not pay attention to the RPM I was turning. I pulled the drive shaft to inspect the splines as I have stripped them on my other ski.

  4. #4
    The oem intake is very restrictive...hell....just opening up the last three feet will get you breathing better. Ah...gotcha....why'd you replace the shoe? I can see my splines well enough without removing the shaft.....dunno about it. How was the ski behaving before you shut her down for a month and a half?

  5. #5
    Overcenter76's Avatar
    Join Date
    Aug 2009
    Location
    St. Cloud, Florida
    Posts
    18
    The pump shoe had the tapped inserts for the grate torn out of it. When I found the impeller splines to be in good shape I wanted to double check the splines that went into the PTO, the ski feels that bad from a dig. In fact, that is why I tore it back down I expected to find a broken part of some sort. When my other ski stripped out the splines on the driveshaft and the impeller it felt better out of the hole. The ski is unrideable.

  6. #6
    they sell a girdle to reinforce the pump shoe for grate bolt retention. As to the rest....I'm at a loss. Have you looked at your sc?

  7. #7
    Overcenter76's Avatar
    Join Date
    Aug 2009
    Location
    St. Cloud, Florida
    Posts
    18
    Yea, I have the R&D girdle on both of my skis now. I'm at a loss as well, I will take a look at the SC and order an intake.

  8. #8
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    Did you use a alignment tool to check the pumpshoe install? Was there any water in the hull? Did you put a OEM wear ring or one of those aftermarket/ EBAY ones in?

  9. #9
    Turbo Doo's from Down Under one1one's Avatar
    Join Date
    Aug 2007
    Location
    Gold Coast, Australia
    Posts
    394
    You replaced the pump support?

    There's your problem, an air leak.

    When fitting a new pump support it is critical that the component is sealed to the hull perfectly.

  10. #10
    Overcenter76's Avatar
    Join Date
    Aug 2009
    Location
    St. Cloud, Florida
    Posts
    18
    No water in the hull and I used all OEM parts. The air leak around the pump shoe is now the front runner. I will take a look.

    Thanks

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 15
    Last Post: 07-02-2013, 10:35 AM
  2. Starter will not come out - HELP
    By heebeha in forum Polaris How To & FAQs
    Replies: 7
    Last Post: 05-23-2012, 03:40 PM
  3. Pump will not come out
    By bbjean10 in forum Polaris Projects
    Replies: 7
    Last Post: 08-13-2011, 12:09 PM
  4. How should my RXP be out the hole.
    By John_29455 in forum 4-Tec Performance
    Replies: 8
    Last Post: 09-27-2008, 04:22 PM
  5. HELP. Intake grate bolts will not come out.
    By mksmi in forum 4-Tec Performance
    Replies: 25
    Last Post: 01-21-2008, 08:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •