Page 1 of 2 12 LastLast
Results 1 to 10 of 19
  1. #1
    Nonstop, all day, everyday. 01xdime's Avatar
    Join Date
    Aug 2005
    Location
    Pasadena, MD
    Posts
    3,682

    Added mods, Now i'm slower!!!!!!!

    I just took out my 03 GTX SC today with a fresh updated SC clutch, Riva BOV, brand new wear ring, free flow exhaust, Riva grate, and smoothed ride plate. I went out with my g/f for a while and didn't really crank into it much. I checked the gps and saw 59.8 and was pleasantly suprised. I dropped her off at the dock and went back out. I made a few passes and checked the gps, 62.6. Wow, now thats sad. On my 3rd run i went to take off and got a check engine code 1202 that went away. Regardless i called it quits. I hit 63.3 bone stock with a half a tank of fuel last year in hotter weather. I was expecting 65 or close to it. Dont get me wrong it's a rocket out of the hole and handles better than before but the top speed is pitifull. Anybody have any ideas?


  2. #2
    Moderator two2curupt's Avatar
    Join Date
    May 2005
    Location
    Toronto, Canada
    Posts
    2,982
    +1
    41
    Check your oil level is'nt too high

  3. #3
    Nonstop, all day, everyday. 01xdime's Avatar
    Join Date
    Aug 2005
    Location
    Pasadena, MD
    Posts
    3,682
    Nope it's about half way up the full area on the dipstick. What numbers do you think i'm seeing? Do you think that check engine code has anything to do with it?

  4. #4
    CRAZEDRXP's Avatar
    Join Date
    Apr 2005
    Location
    PHILADELPHIA
    Posts
    843
    its the intake grate ..for top speed the stock one is the best i have gps and many hrs to proove this .... .. I recently put my stck grate back on and i picked up nearly 2 mph in calm water ... them intake grates im beggining to think are a another scam

  5. #5
    CRAZEDRXP's Avatar
    Join Date
    Apr 2005
    Location
    PHILADELPHIA
    Posts
    843
    also just to add that free flow exshaust .. is that the hole one from ppg??? or just the small 8 inch piece?? if its the hole one thgen that also is hurting u because of the lack of back pressure u may need the one with the resonator ..

  6. #6
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,980
    +1
    1,898
    xdime, temporarily remove your BOV and see if your speeds come back.

    Crazed, no offence, but there is no way the Riva grate is scrubbing 2 MPH. You have so many other problems with your ski so it's easy for you to blame your speed loss on this, or blame it on that.
    I too thought my Riva grate was scrubbing speed so I put my stock grate back on and I lost .5 mph. Oh, this was a back to back test 30 minutes apart.

    On the power pipe from PPG. Remember some months back when you called me in a panick (typical ) saying you lost nearly 2 mph from using the power pipe? I gotta admit, you got me to thinking and worrying. I left work early, pulled my PPG power pipe off and put the stock hose back on. Headed to the water to test "your theory" and saw that I lost 150 RPM's and nearly 1 mph. So there again, your power pipe theory doesn't hold water with me.

  7. #7

  8. #8
    way2fast's Avatar
    Join Date
    May 2005
    Location
    Melbourne Beach, FL
    Posts
    4,013
    +1
    3
    Josh; The mods can not be causing you to loose speed. Something else is wrong. ??????????????

    Richard

  9. #9
    Moderator boataddict's Avatar
    Join Date
    Apr 2005
    Location
    Ottawa, Ontario, Canada
    Posts
    3,818
    +1
    38
    I always thought that backpressure was not a friend to the performance of a 4 stroke? You need it on a 2 stroke though.

  10. #10
    CRAZEDRXP's Avatar
    Join Date
    Apr 2005
    Location
    PHILADELPHIA
    Posts
    843
    I dont take no offense at all HOWEVER jerry please compare apples to apples .. your ski and my ski are two diff monsters as is your ski and most other skis ... .. I already prooved to myself and many others that the grate on flat calm water hurts your top speed .. when I say your i mean skis with basic bolt ons ... actually if u call riva directly and ask them they will be honest esc. mark ext 349 at riva and he himself will tell you that on calm water you will oose as much as 1.5 maybe 2 mph with the addition of the riva grate ... there claim is that in CHOP you dont gain anything at all you JUST DONT LOOSE speed .... Now as for the pipe again i am not trying to argue with you jerry but how can u question Glenn and many others that have GPSed there skis??????????? why does glenn make a pipe with a resonator??? why does he himself say that IF YOUR SKIS IS BASICALLY STOCK YOU NEED THE PIPE WITH THE RESONATOR??? Remeber jerry you can no longer comapre your ski to mine or many others once you did heads and cams you have a TOTALLY DIFF SET UP , a completley diff ski ... i myself have gpsed back to back and saw 2 mph on glass water with the riva grate i have no reason at all to make something l;ike this up ... the grate to me is a scam and if you go on rivas board you will see a whole threqad about someone that did the same tests and agrees with me 100% that grate does nothing at all for normal everyday riding NOTHING .... now however maybe it does on YOUR SKI with YOUR set up ..... i am speaking for people that have basic bolt ons ... the power pipe im not quite sure how u can tell me that after i installed a pipe with a resonator i didnt pick up nearly a 1000 rpms and 1.5 mph??? i to did back to back testing as per glenn I ran my ski for a full day with the basic pipe then on the water not even on the trailor my cousin and i quickly swapped out pipes for one that had a resonator in it and i have since kept that pipe ... jerry dont take this the wrong way I am not questioning your knowledge but you have to compare apples to apples not oranges ... you no longer have a 04 rxp 1494 cc .... im not the only one that says them grates are a scam and them pipes hurt you ..

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New Mods...Now having problems!!
    By 01yamigpr1200r in forum Yamaha PWC Performance (2-stroke)
    Replies: 8
    Last Post: 04-11-2010, 11:03 PM
  2. what next mod (now C kit sc)
    By tottii in forum 4-Tec Performance
    Replies: 5
    Last Post: 12-23-2009, 12:21 PM
  3. Adding mods, what prop do i get?
    By Dave0 in forum 4-Tec Performance
    Replies: 2
    Last Post: 06-02-2009, 12:34 PM
  4. new mods now low RPM miss
    By shhr in forum 4-Tec Performance
    Replies: 15
    Last Post: 05-21-2009, 08:30 AM
  5. Adding Mods
    By JonnyRXT in forum 4-Tec Performance
    Replies: 2
    Last Post: 02-14-2009, 05:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •