Results 1 to 5 of 5
  1. #1
    Super7Four's Avatar
    Join Date
    Jul 2008
    Location
    Philadelphia Area
    Posts
    34

    Help with 15F RPM kit performance

    I have a 2008 15F with about 65 hrs and seem to be slowly losing top speed performance. I basically have the RPM kit except I have a shredmaster ride plate. I'm getting 7600-7800 rpms but my top speed on GPS is barely getting above 60. I used to get up to around 64.

    (It's been incredibly hot where I live so water temps are higher than normal for this time of year)

    Any simple suggestions of things that could be causing this?

    Thanks for your help


  2. #2

    Join Date
    May 2008
    Location
    Dallas, TX
    Posts
    21
    Well in my opinion that points to a pump
    problem. If the rpm's are there like you
    say they are it has to be pump related. How
    do you like that ride plate?? I want to get
    the same one.

  3. #3
    Super7Four's Avatar
    Join Date
    Jul 2008
    Location
    Philadelphia Area
    Posts
    34
    Hey texas....I think you sent me a pm before about the ride plate. I like it. I definitely recommend over stock. Can't compare it to anything else.

    What are your suggestions regarding the pump?

  4. #4
    My name is Sean and I am addicted to STXs smokeysevin's Avatar
    Join Date
    May 2008
    Location
    Houston
    Posts
    4,485
    +1
    320
    check the pump bearings

    Sean

  5. #5

    Join Date
    May 2008
    Location
    Dallas, TX
    Posts
    21
    You did send me a PM about the plate and I realized it was you right after I posted my reply - sorry about that. I agree with Smokeysevin - sounds like pump bearings. I would pull it apart and inspect it. That really is all it could be. Your engine is obviously turning the necessary rpm's you just aren't getting the power to the water. Check your ride plate, intake grate and entire pump assembly. 99.9% sure it is the pump. There are definitely guys on here that are more knowledgeable about pumps than I am - they should be able to tell you what signs to look for or perhaps a search will yield you some good results. Good luck and let us know what it ends up being.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS 2006 kawasaki15f mint!! with riva rpm kit
    By wave15stx in forum Kawasaki Skis
    Replies: 24
    Last Post: 05-18-2010, 11:24 AM
  2. SHO vs. RXP 215 vs. 15f (RPM KIT)
    By matrixman16 in forum Sea Doo Open Discussion
    Replies: 37
    Last Post: 04-29-2009, 09:05 PM
  3. need help with Riva Endurance kit
    By inchadeboca in forum Kawasaki PWC Performance (4-stroke)
    Replies: 13
    Last Post: 08-01-2008, 06:35 AM
  4. 15F RPM Kit breather broke off
    By firehawk in forum Kawasaki PWC Performance (4-stroke)
    Replies: 4
    Last Post: 06-21-2007, 11:40 AM
  5. 15f rpm kit owners come in
    By firehawk in forum Kawasaki PWC Performance (4-stroke)
    Replies: 10
    Last Post: 06-01-2007, 02:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •