Results 1 to 5 of 5
  1. #1

    No spark on 2000 Virage

    New here, I have a 2000 Virage that i can not get to spark but if i hold down the bilge pump button it will start and run till i let go of the button and then dies. Also the 15 amp reset button will pop out sometimes. Any help would be appreciated, thanks


  2. #2
    casey67's Avatar
    Join Date
    Sep 2006
    Location
    Lemont,IL
    Posts
    2,571
    +1
    34
    Welcome to Green Hulk !

    Sounds like the LR module/ voltage regulater is not working. Search-there are a couple threads that cover the testing.

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,575
    +1
    1,272
    Welcome

    LR regulator module would be the primary suspect, given those symptoms.

    Polaris PWC Parts Sources

  4. #4
    i have two jet skis identical and i switched electrical boxes and the problem stayed with the jet ski not the box and from what i can tell the LR regultor is in there correct?

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,575
    +1
    1,272
    Check the stator ohms, especially the Yellow to Red/Purple charging coil. If it is open, you will not have battery charging, AND you will not have RPM signal to the LR module.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2000 slx 1200 no spark on middle cylinder
    By gooey83 in forum Polaris Tech Tips and Info
    Replies: 41
    Last Post: 02-11-2017, 09:35 AM
  2. 2002 Virage I (No Spark on one cylinder)
    By fcflores1 in forum Polaris How To & FAQs
    Replies: 7
    Last Post: 08-05-2016, 11:59 AM
  3. 2000 kawasaki 1100 stx di "No Spark on all 3 cylinders"
    By xboxmodman in forum Kawasaki PWC Performance (2-stroke)
    Replies: 26
    Last Post: 06-03-2012, 07:05 PM
  4. help plzzz no spark on my 02 virage txi
    By Corey_ in forum Polaris PWC Performance
    Replies: 3
    Last Post: 10-19-2011, 07:27 PM
  5. 2000 kawasaki 1100 stx di "No Spark on all cylinders"
    By xboxmodman in forum Kawasaki Open Discussion
    Replies: 1
    Last Post: 06-20-2011, 11:39 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •