Results 1 to 4 of 4
  1. #1

    Join Date
    Jan 2010
    Location
    Upstate new york
    Posts
    14

    seadoo rx wont start maintenance light on

    got an 01 seadoo rx ran fine saturday took it out sunday and the maintenance light came on it wasnt spitting water out of the side for some reason we hooked it up to a hose today and it turned over fine however the light was still on it doesnt make any beeping except the regular 2 beeps but it flashes maint ten times then finally goes away i then decided to try and put it in the water to see if it would run and it wouldnt even turn over the engine kind of make an eek noise if anyone could try and help explain what could be wrong it would be appreciated


  2. #2
    KrunchovXPL-GTX-RX's Avatar
    Join Date
    Mar 2009
    Location
    Aiken, SC
    Posts
    1,391
    +1
    1
    Did it start on the trailer, or just turn over? Two different things (and it is very important).

    You should never, EVER, have the hose turned on when the engine is not running.

    Do not worry about the Maintenance message if it is not a DI. Likely it is just the 25/50 hour flag that they hope will get you to take it to the dealer (this can be cleared by holding
    the mode and set buttons when the message comes on until it goes away).

    If it is a DI then you are probably looking at a trip to the dealer to find out what is wrong.

    Now, if you had the hose turned on while trying to get it to start you have a much larger problem. You need to charge your battery, take the spark plugs out, stand back,
    and hit the start button. You need to stand back to avoid the bulk of the oily water that is about the come shooting out of your engine.

    Your battery may ultimately be at fault and will need to be replaced (though I would want to know why it was not pissing, a clog in the cooling system somewhere, it would seem, or perhaps a problem at the pipe flange).
    Thus, you will need a new battery if this is the case and it will take a strong battery to get all that water out. Once that is done, if you can not get it to start you will need to
    fog the living crap out of it while you turn it over by hand and on the starter.

    Keep in mind, no more then ten seconds at a time on the starter with a few minutes in between to cool off. You can burn up a starter clearing one real easy.

  3. #3

    Join Date
    Jan 2010
    Location
    Upstate new york
    Posts
    14
    its the carb model not the di im pretty sure we had it started on the trailer yesterday but the hose was deffinitly running while the engine was off because i just went and took out my plugs and all kinds of crap shot out when i turned it over

  4. #4
    KrunchovXPL-GTX-RX's Avatar
    Join Date
    Mar 2009
    Location
    Aiken, SC
    Posts
    1,391
    +1
    1
    Get it cleared out ASAFP!

    Then either get it to run or shoot a whole can of fogging oil into it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Maintenance light on SeaDoo 2001 GTX Di
    By solaria in forum 2-Stroke Performance
    Replies: 16
    Last Post: 06-11-2015, 09:55 PM
  2. 1996 Seadoo spx wont start after sitting on water
    By pwcnick in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 07-12-2012, 07:26 AM
  3. xlt1200 wont start says code on dash
    By tgersx in forum Yamaha How To & FAQs
    Replies: 2
    Last Post: 11-07-2009, 05:56 PM
  4. reseting maintenance light on xpdi
    By macattack in forum 2-Stroke Performance
    Replies: 1
    Last Post: 07-05-2009, 07:06 AM
  5. maintenance light on a 1997 gtx
    By ultra150nc in forum 2-Stroke Performance
    Replies: 9
    Last Post: 05-30-2008, 09:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •