Results 1 to 3 of 3
  1. #1

    Join Date
    Apr 2010
    Location
    Philadelphia PA
    Posts
    82
    +1
    3

    1999 LS 2000 65u Engine Failure.. Please help!

    Hey Guys,

    I am having some trouble with my LS 2000. I had an engine fail at the begining of the season. The rod bearing closest to the flywheel went bad welding the rod to the crank. I had a machine shop rebuild it with a hotrod crank and new pistons the whole nine yards. I replaced the oil injection lines, resecured them and changed the oil (just as precaution, couldent justify this as the engine failure). After 2 hours of use with the new engine, the other engine failed! I just pulled it out and tore it down to the block and the same exact thing is wrong with it! Is it a common thing for the 65u to have this rod bearing fail? I have had GP1200's with the 65u and never had a problem! In conclusion, no burnt pistons, no scoring, plenty of oil (Premix gas plus oil injection), Any thoughts before i put another $1200 motor in there? Thanks


  2. #2
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,011
    +1
    283
    No, very unusual--especially to happen to both engines. My guess is that the engines were submerged or the flush hose was left running after the engine was turned off, allowing water to enter the engine. This would rust the bearings and cause them to fail at a later time.

  3. #3

    Join Date
    Apr 2010
    Location
    Philadelphia PA
    Posts
    82
    +1
    3
    Yes perhaps the previous owner dident take care of it as well as i thought, he mentioned is hasent been used in a few years. Hopefully after this rebuild i will be in the clear, the guys in the machine shop are going to tear me up when i walk in with another engine tomorrow, haha. Thanks for the response. I take care of my stuff, i am just nurvous i am overlooking a problem to cause these to fail.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. SHO Cruiser 2008 Engine Specialists - please help
    By wazza in forum Yamaha PWC Performance (4-stroke)
    Replies: 5
    Last Post: 05-25-2009, 07:38 PM
  2. 02' Yamaha GP1200r - Engine Trouble - Please HELP!!!
    By 02YamahaGP1200r in forum Yamaha PWC Performance (2-stroke)
    Replies: 12
    Last Post: 04-26-2009, 05:52 PM
  3. 02' Yamaha GP1200r - Engine Trouble - Please HELP!!!
    By 02YamahaGP1200r in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 04-26-2009, 03:44 PM
  4. Need advice on engine repair, please help!
    By iolaus in forum 4-Tec Performance
    Replies: 41
    Last Post: 07-16-2008, 10:31 PM
  5. Major engine troubles - please help !
    By Shawn001ca in forum Polaris Open Discussion
    Replies: 28
    Last Post: 06-20-2007, 10:16 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •