Results 1 to 3 of 3
  1. #1
    RumRunnerRon's Avatar
    Join Date
    Mar 2010
    Location
    Portland, Oregon
    Posts
    462

    Trim gauge won't go up past center mark but it goes down

    First day out on the lake for vacation rounded this corner and found nothing but hard chop. Really bad. To busy to look down at the gauges to see if that's when my problem occured. It was towards the end of the day any way so headed in. The next day is when I noticed the gauge wouldn't move up past center. Never has done this before. When using the switch in both directions it felt like it was going up and down. The bow would rise and fall. Did a visual inspection out of the water and it kind of looks like its up all the way. Just the gauge not going up past center but, it does go all the way down. Could the hard chop have caused something to go out of phase? How does the VTS module work as far as sending unit is concerned? Searched the manual lol that was no help. Thank you in advance for any help guys.


  2. #2
    Work Harder, Millions on Wellfare Depend On Us! ultramaxracing05's Avatar
    Join Date
    Aug 2009
    Location
    Beaumont, Texas
    Posts
    2,999
    +1
    123
    could be a loose connection,

    I have a new in the box gauge that I'l let go for cheap if you think you'l need one.

  3. #3
    RumRunnerRon's Avatar
    Join Date
    Mar 2010
    Location
    Portland, Oregon
    Posts
    462
    Quote Originally Posted by ultramaxracing05 View Post
    could be a loose connection,

    I have a new in the box gauge that I'l let go for cheap if you think you'l need one.


    Thanks for the offer. Pretty sure it's not the gauge though. It lights up but wont go up past the half way mark. Jet nozzle moves too. Took a bit of searching but found some info on here that had a decent schematic to look at. May have just broken on or more of the glass reed switches in the vts module. If that be the case may just live with it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 2
    Last Post: 07-26-2016, 12:46 AM
  2. Replies: 2
    Last Post: 09-22-2010, 06:33 PM
  3. 98 stx won't go past 8mph...rpms do increase
    By mymaries1806 in forum Kawasaki Open Discussion
    Replies: 3
    Last Post: 07-04-2009, 08:07 AM
  4. won't go past 20mph/4200 RPM
    By jeff0810 in forum Polaris Open Discussion
    Replies: 6
    Last Post: 08-16-2008, 08:21 PM
  5. Won't go past 2750 RPM
    By immred in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 07-02-2007, 06:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •