Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12

Thread: RFI Just Clicks

  1. #1
    olds72's Avatar
    Join Date
    Nov 2009
    Location
    Toledo, OH
    Posts
    173
    +1
    1

    RFI Just Clicks

    More trouble in paradise! Last week while riding my ski stalled (again) I couldn't get it restarted, It just started clicking. I thought it was the starter relay, so I bought a new one. No dice, it still just clicks. I tried to jump across the relay and nothing. the battery shows 12.7 Vdc on my meter. Is it the starter?


  2. #2
    Work Harder, Millions on Wellfare Depend On Us! ultramaxracing05's Avatar
    Join Date
    Aug 2009
    Location
    Beaumont, Texas
    Posts
    2,999
    +1
    123
    you tried jumping the starter solenoid?
    and only clicked, sounds like the starter might be the problem when you jump the solenoid it directly directs power to the starter, nothing else its in its way. try turning the pto by hand and jump it again. your starter might be just on the way out

  3. #3
    olds72's Avatar
    Join Date
    Nov 2009
    Location
    Toledo, OH
    Posts
    173
    +1
    1
    I did that and nothing. Wish I could get a BFH in there! I'd give it a whack!

  4. #4
    olds72's Avatar
    Join Date
    Nov 2009
    Location
    Toledo, OH
    Posts
    173
    +1
    1
    How do I test the starter?

  5. #5
    ktyamaha36's Avatar
    Join Date
    Sep 2009
    Location
    Winter Haven,FL
    Posts
    303
    Jumping the solenoid is the only way to test the starter while still on the engine. Only other way is to take it off . Ive got by for a weekend by taking a long extension and touching the side of the starter with one end and giving the other end a couple "love taps" with a hammer. Not too hard or you will damage it. Sometime this frees them up.

  6. #6
    olds72's Avatar
    Join Date
    Nov 2009
    Location
    Toledo, OH
    Posts
    173
    +1
    1
    looks like I put a new starter in then! Look like it's going to fun to get it out.

  7. #7
    Just put one in mine... Not a fun job putting the bracket back on but with a little patience you'll get it.

  8. #8
    olds72's Avatar
    Join Date
    Nov 2009
    Location
    Toledo, OH
    Posts
    173
    +1
    1
    Just put my starter in. I had some trouble with the back bolt, but it's in and it started right up. Picking up a heavy duty rectifier from seadoosource tomorrow. Then I'll be out for a test ride.

  9. #9
    Work Harder, Millions on Wellfare Depend On Us! ultramaxracing05's Avatar
    Join Date
    Aug 2009
    Location
    Beaumont, Texas
    Posts
    2,999
    +1
    123
    i believe seadoosource is out of the country, unless he is back.

  10. #10
    olds72's Avatar
    Join Date
    Nov 2009
    Location
    Toledo, OH
    Posts
    173
    +1
    1
    Quote Originally Posted by ultramaxracing05 View Post
    i believe seadoosource is out of the country, unless he is back.
    He's been back for a few weeks. I talked to him on the phone.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2000 Seadoo GTX RFI won't crank, just clicks
    By normr in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 05-28-2015, 08:50 AM
  2. just click but no crank
    By payasito in forum Polaris Open Discussion
    Replies: 1
    Last Post: 07-20-2010, 05:44 PM
  3. rfi just.....died
    By mibunkerking in forum 2-Stroke Performance
    Replies: 6
    Last Post: 07-24-2009, 06:39 AM
  4. 04 gtx sc just clicks
    By mooneyb91084 in forum 4-Tec Performance
    Replies: 5
    Last Post: 05-28-2008, 07:45 PM
  5. Solenoid just clicks
    By gerhand44 in forum Polaris How To & FAQs
    Replies: 7
    Last Post: 10-24-2006, 02:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •