Results 1 to 10 of 10
  1. #1
    Drumdog's Avatar
    Join Date
    Jun 2010
    Location
    Liberty Lake, WA
    Posts
    8

    '08 VX Cruiser power loss

    Ok...my first shot at owning a pwc.
    I just bought a 2008 VX Cruiser with 14.5 hours on it.
    The wife and I got on it and took off and got it up to 43 mph.(390 pounds between us)
    We rode for about 5 minutes and then I started losing power.
    The max speed I can get now is 30mph.
    It idles just fine, but the hole shot is almost non-existent.
    I didn't take on any water, so that's not it.
    What should I look for as the cause?

    Help a noob out?

    Thanks !


  2. #2
    This is my place of Zenn smohammed's Avatar
    Join Date
    Oct 2009
    Location
    Trinidad & Tobago / Broward FL
    Posts
    264
    +1
    1
    mmm if you are getting a sort of vibration or something of a vibrating sound, u can 1st check your intake to see u sucked up anything.. 2nd u might want to check your plugs and change them.. assuming if the 10 hour service wasnt done, you might wanna consider changing your plugs and oil.

  3. #3
    SHO-08's Avatar
    Join Date
    Jan 2010
    Location
    SFlorida
    Posts
    115
    Quote Originally Posted by Drumdog View Post
    Ok...my first shot at owning a pwc.
    I just bought a 2008 VX Cruiser with 14.5 hours on it.
    The wife and I got on it and took off and got it up to 43 mph.(390 pounds between us)
    We rode for about 5 minutes and then I started losing power.
    The max speed I can get now is 30mph.
    It idles just fine, but the hole shot is almost non-existent.
    I didn't take on any water, so that's not it.
    What should I look for as the cause?

    Help a noob out?

    Thanks !
    Was it your 1st time out on it? Had you rode it 2 up before & it was faster?
    The reason I ask just in case it was an existing problem... but it does sound like you sucked something up like smo already said.
    If you dont know how just ask : )

  4. #4
    Drumdog's Avatar
    Join Date
    Jun 2010
    Location
    Liberty Lake, WA
    Posts
    8
    That was the first time I had ridden it.
    I bought it this afternoon, took it out, rode for 5 minutes and down went the power.
    No weird vibration...

    How do I check for something being sucked up?

  5. #5
    Drumdog's Avatar
    Join Date
    Jun 2010
    Location
    Liberty Lake, WA
    Posts
    8
    Ok...so I crawled under it and there is nothing stuck in the intake.
    I guess I'll change the plugs and see if that helps.
    Any other suggestions would be greatly appreciated.

  6. #6
    it's most likely the plugs went bad, had the same issue with my 2008 FX HO, change the plugs and she'll run like new...

  7. #7
    Drumdog's Avatar
    Join Date
    Jun 2010
    Location
    Liberty Lake, WA
    Posts
    8
    Should I stay with the stock NGK CR9EB's ?
    Quote Originally Posted by skeeterzx225 View Post
    it's most likely the plugs went bad, had the same issue with my 2008 FX HO, change the plugs and she'll run like new...

  8. #8
    that's what I put in, I think it's more a matter of how the jetski was winterized last fall than issues with the plug type..at least it's quick and easy to change plugs, my Yamaha Snowmobile requires alot of work to switch plugs..

  9. #9
    Drumdog's Avatar
    Join Date
    Jun 2010
    Location
    Liberty Lake, WA
    Posts
    8
    Changed the plugs and now she flies across the water !

    Thanks for the help !!

  10. #10
    This is my place of Zenn smohammed's Avatar
    Join Date
    Oct 2009
    Location
    Trinidad & Tobago / Broward FL
    Posts
    264
    +1
    1
    now get out there and tear it up

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS - Parts 08 vx cruiser part out
    By tobefast in forum Yamaha 4 Stroke Skis
    Replies: 0
    Last Post: 06-29-2014, 05:04 PM
  2. 08 VX Cruiser issue
    By NickG in forum Yamaha PWC Performance (4-stroke)
    Replies: 14
    Last Post: 07-06-2012, 08:00 PM
  3. '08 VX Cruiser - Observations
    By Ventureowner in forum Yamaha PWC Performance (4-stroke)
    Replies: 30
    Last Post: 10-24-2011, 09:07 AM
  4. Maiden Voyage '08 VX Cruiser
    By Ventureowner in forum Yamaha Open Discussion
    Replies: 0
    Last Post: 08-04-2008, 12:18 AM
  5. '08 VX 110 Cruiser Cover
    By Ventureowner in forum Yamaha PWC Performance (4-stroke)
    Replies: 4
    Last Post: 07-30-2008, 05:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •