Results 1 to 4 of 4
  1. #1
    mudbug660's Avatar
    Join Date
    May 2010
    Location
    Lafayette, La
    Posts
    57

    High high idle 4100 rpm!!!

    I just got through tearing down the putting it back together and adding 42lb injectors, XS IC, S3 charger and riva rear air intake.I cranked it up the other day on the trailer with the water hose and it idled fine, 1800ish. I brought the ski out to the lake today for a test and it was idling around 3500rpm
    Got it out of the lake and cranked it up real quick and 4100 rpm.
    What the crap would cause this?

    Would the idle bypass valve make it rev this high?


  2. #2
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    Quote Originally Posted by mudbug660 View Post
    I just got through tearing down the putting it back together and adding 42lb injectors, XS IC, S3 charger and riva rear air intake.I cranked it up the other day on the trailer with the water hose and it idled fine, 1800ish. I brought the ski out to the lake today for a test and it was idling around 3500rpm
    Got it out of the lake and cranked it up real quick and 4100 rpm.
    What the crap would cause this?

    Would the idle bypass valve make it rev this high?
    Check your throtle cable on the throtle body that its closing all the way. It can get hung up by a wire, etc.
    If it is ok and the butterfly is completely closing the you likely have a vacumn leak on the intake manifold.

  3. #3
    mudbug660's Avatar
    Join Date
    May 2010
    Location
    Lafayette, La
    Posts
    57
    Quote Originally Posted by skoepp View Post
    Check your throtle cable on the throtle body that its closing all the way. It can get hung up by a wire, etc.
    If it is ok and the butterfly is completely closing the you likely have a vacumn leak on the intake manifold.
    DING DING DING!!! That's it!
    Apparently I forgot to tighten up the brass plugs on the IC block off plug. So all three of them are chillin under the engine. I hope they have a long prosperous life under there. I put my fingers over the holes and it idled regular. I'll get it fixed tomorrow.
    Problem solved!!


    Thanks for the reply,

  4. #4
    Banned User
    Join Date
    Aug 2009
    Location
    Discovery Bay, CA
    Posts
    3,048
    +1
    336
    haha get those buggers out of there. put the ski on the trailer, pick the front up real high and grab them out of the back!!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. High idle RPM after hard buoy riding?
    By skigolfnut in forum 4-Tec Performance
    Replies: 12
    Last Post: 02-06-2013, 02:33 PM
  2. RXP, High Idle, Low RPMS? --Help me out!
    By RX-Pike in forum 4-Tec Performance
    Replies: 33
    Last Post: 07-25-2009, 10:42 PM
  3. High Idle 2200-2400 RPM help...
    By jayzauto64 in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 07-23-2008, 01:03 PM
  4. HIgh Idle on 07' RXP???
    By NJRXP in forum 4-Tec Performance
    Replies: 6
    Last Post: 05-18-2007, 12:10 PM
  5. 04 rxp 'sensor' /high idle/trim gauge
    By cdooRXPxtrm in forum 4-Tec Performance
    Replies: 1
    Last Post: 07-17-2006, 09:54 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •