Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1
    MR MAC's Avatar
    Join Date
    Feb 2010
    Location
    Essex, England
    Posts
    450

    Help.....70.9mph and gutted!!!!

    hi all....been out today on a 6" chop/smooth. was 25 degrees and 22 degrees water temp.... i had 8000rpm and afrs were 10.5 idle 12 at low power 13 at 6000rpm ish and 11.5 WOT....... as per my sig i was only able to get 70.9 mph and was expecting a few more than that..... what can i change to get closer??


    thanks ian


  2. #2
    wakeboardmuppet's Avatar
    Join Date
    Jul 2008
    Location
    Lancashire, England, UK
    Posts
    206
    That's not good E

    Mine did 72mph with that impeller and no R2 reflash. 7400rpm as well ? ?

    No idea what's causing it though. Someone will

    Have you got access to a standard impeller to get the revs upto 8500rpm. That got mine over 78 with Corkys reflash. Mine should be here this coming week.Just need the clutch parts now, although I stripped and rebuilt my clutch and it works perfectly now, off the ski mind you

  3. #3
    THE PLATE MAN JIM'S PERFORMANCE's Avatar
    Join Date
    Nov 2005
    Posts
    6,194
    +1
    536
    Quote Originally Posted by MR MAC View Post
    hi all....been out today on a 6" chop/smooth. was 25 degrees and 22 degrees water temp.... i had 8000rpm and afrs were 10.5 idle 12 at low power 13 at 6000rpm ish and 11.5 WOT....... as per my sig i was only able to get 70.9 mph and was expecting a few more than that..... what can i change to get closer??


    thanks ian
    Hello Ian, water temp. 72f and air temp 77f that is a awesome day for numbers. What does not sound right is if you are turning a true 23 pitch at 8000 RPM your speed would be closer to the upper 70s with the mods you have you should be running around a true 21 pitch.

  4. #4
    MR MAC's Avatar
    Join Date
    Feb 2010
    Location
    Essex, England
    Posts
    450
    i have adjusted the pipe work between sc and intercooler with bov on it as i think it may of been leaking..... bov was noticably louder today but was too rough to get any numbers... but it felt better!! could this have been loosing me speed?

    and could my gps be a little out as the readout on the dash is 77mph but gps was 70.9???


    thanks ian

  5. #5
    maxadrenaline's Avatar
    Join Date
    Nov 2007
    Location
    RETIRED !! In Mobile AL or Wherever I Want To Go
    Posts
    1,414
    +1
    137
    You should be a lot faster with those mods. Check your intake grate to see if it is too low in the water. Too much drag going on somewhere !!

  6. #6
    MR MAC's Avatar
    Join Date
    Feb 2010
    Location
    Essex, England
    Posts
    450
    It is a full 70l of fuel in the tank...

    Ian

  7. #7
    I wanna go fast perk_1405's Avatar
    Join Date
    Nov 2009
    Location
    winnabow, nc
    Posts
    202
    Quote Originally Posted by MR MAC View Post
    i have adjusted the pipe work between sc and intercooler with bov on it as i think it may of been leaking..... bov was noticably louder today but was too rough to get any numbers... but it felt better!! could this have been loosing me speed?

    and could my gps be a little out as the readout on the dash is 77mph but gps was 70.9???


    thanks ian
    the gps is prob right, the dash spedo is crap

  8. #8
    maxadrenaline's Avatar
    Join Date
    Nov 2007
    Location
    RETIRED !! In Mobile AL or Wherever I Want To Go
    Posts
    1,414
    +1
    137
    Quote Originally Posted by MR MAC View Post
    It is a full 70l of fuel in the tank...

    Ian
    I ran 69.4 and 69.7 with full tank and 3/4 tank. All I have on my FZS is ribbon removed and HKS BOV. Stock intake grate, stock air box. That is why I think it is either ride plate or intake grate issue slowing you down on your ski.

  9. #9
    MR MAC's Avatar
    Join Date
    Feb 2010
    Location
    Essex, England
    Posts
    450
    boost leaks i think.....

    thanks all

    ian

  10. #10
    maxadrenaline's Avatar
    Join Date
    Nov 2007
    Location
    RETIRED !! In Mobile AL or Wherever I Want To Go
    Posts
    1,414
    +1
    137
    Quote Originally Posted by MR MAC View Post
    boost leaks i think.....

    thanks all

    ian
    Good luck Ian.
    Let us know how it works out. I will be doing the same mods as you and everyone else.
    Thanks,
    chuck

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. help out Xlint and myself...
    By absentx in forum Polaris Open Discussion
    Replies: 17
    Last Post: 08-26-2007, 08:31 AM
  2. Need help removing pistons and bendix
    By cretamk in forum 2-Stroke Performance
    Replies: 6
    Last Post: 07-16-2007, 08:35 PM
  3. Help! Pulse line and fuel shut off ??????
    By lodough780 in forum Polaris Open Discussion
    Replies: 10
    Last Post: 05-24-2007, 04:59 PM
  4. need help polaris sl650 and sltx1050
    By grifter in forum Polaris How To & FAQs
    Replies: 11
    Last Post: 04-29-2007, 09:12 PM
  5. HA! HA! Went and tore it up today. mid 70's and sunny.
    By Water4fire in forum 4-Tec Performance
    Replies: 34
    Last Post: 01-01-2006, 09:23 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •