Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 32
  1. #1
    Kaybat's Avatar
    Join Date
    Aug 2005
    Location
    Fl
    Posts
    1,735
    +1
    28

    checked my pump bearings today

    1st time(165 hrs)something tells me this ain't good(lol)
    bearings feel ok....(although i thought i heard a faint whining idling today)
    need some feedback,
    should i just repack the thing,replace the o rings and hope for the best,or am i screwed??Thanks


  2. #2
    home of the dislexic fingers breon's Avatar
    Join Date
    Aug 2007
    Location
    port st lucie fl
    Posts
    3,471
    i found mine just about like that..about a month ago...took it apart... bearrings were fine ...cleaned it all out... replaced 50 bucks worth of seals ...repacked it ....

    check the o rings on the pump cone arnt torn before you replace all the seals...

  3. #3
    Kaybat's Avatar
    Join Date
    Aug 2005
    Location
    Fl
    Posts
    1,735
    +1
    28
    thanks.....i'm thinkin' the same.....should cone be fully loaded with grease??cause it wasn't even close....props to brp though for building a troublefree pump!!

  4. #4
    home of the dislexic fingers breon's Avatar
    Join Date
    Aug 2007
    Location
    port st lucie fl
    Posts
    3,471
    doesnt neet to be completely full but close...it isnt that common.. i ride with a guy that has 600 hours on his nad never had and issue..

  5. #5

    Join Date
    Nov 2007
    Location
    Branson, MO area
    Posts
    190
    +1
    1
    We are getting ready to rebuild a pump in the next few days. We have a press but not the bearing an seal pusher. Can we get by with sockets and such?

  6. #6
    home of the dislexic fingers breon's Avatar
    Join Date
    Aug 2007
    Location
    port st lucie fl
    Posts
    3,471
    that is what i used..they dont press real hard

  7. #7
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Ken... at 165 hrs do a full rebuild on that pump! The front shaft seals are leaking, not the o-rings on the cone.

  8. #8
    Kaybat's Avatar
    Join Date
    Aug 2005
    Location
    Fl
    Posts
    1,735
    +1
    28
    What seal needs to be replaced Brian? I don't know the 1st thing about rebuilding a pump....my only altenative is a dealer...the bearing appears to be perfect...thinking i might just repack the thing and do it after warm weather.....not sure.

  9. #9
    home of the dislexic fingers breon's Avatar
    Join Date
    Aug 2007
    Location
    port st lucie fl
    Posts
    3,471
    he is talking about the seals in the front ...there is a c clip in the front then the seals come out and there is another o ring and berring under it..you need to take it apart and replace the seals at the minimum....i was just saying check the o rings..in the tail cone as well...sometimes they get damaged ..taking it on and off to repitch..if you leave it like that... the water will destroy the berrings then the wear ring..possibly prop..and drive shaft...

    when i found mine i was on and off with the prop trying to get it pitched right..so i know i caught mine the first time it leaked..

    the seals are only about 50 bucks...or 1 tank of gas in the ski

  10. #10
    Kaybat's Avatar
    Join Date
    Aug 2005
    Location
    Fl
    Posts
    1,735
    +1
    28
    thanks dude,just to clarify, i need to pull prop to get to the front seal(s)?

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Checked my exhaust filter today...
    By DH300 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 11
    Last Post: 05-28-2014, 11:40 AM
  2. check your pump bearings
    By corkycat in forum Yamaha PWC Performance (4-stroke)
    Replies: 27
    Last Post: 09-10-2010, 08:33 AM
  3. Is my pump bearing failing?
    By cooldaddy in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 07-12-2010, 06:45 AM
  4. Got my pump today!
    By Totallyblown in forum Sea Doo Open Discussion
    Replies: 13
    Last Post: 05-25-2006, 09:16 PM
  5. Got my pump back from Skat Trak today
    By Mark S in forum 4-Tec Performance
    Replies: 13
    Last Post: 07-04-2005, 08:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •