Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 22
  1. #1

    2008 Kawasaki STX-15F Running Rough

    So my 2008 Kawasaki STX-15F 59 Hours on it. I went out for the first time this season i know it seems crazy but I have been so busy with work...anyways I went out and it runs really rough goes up to about 5000RPMS and goes about 30 mphs....So I replaced the plugs and put fuel injection cleaner in. Now it runs the way it should when it is on the tralier, but as soon as I put it in the water it runs to where the Engine goes about 5000RPMS then it stalls out smells very gassy and seems like it is flooding its self...any ideas?? Thanks


  2. #2
    I just ran into the same problem today. went out and it was ok for the first 10 min, then engine rpms fell and it seemed like spark plug went bad, so i went home replaced them and same thing is happening.

    With new spark plugs i went out and it worked for like 5 min then Rpms fell all the way down until it would stall and engine would turn on. Starts up with a bit of gas but then again stalls. so i had it towed back to the marina. 10 min later it started up and went 30mph max and again would start to die out so i made it back to the marina. Brought it back home and it seems to work fine but sometimes in the idle i can feel that rpms are fall and it loses 1 rpm bars on the meter. What steps do i need to take to fix this myself. really appreciate it.

  3. #3
    My name is Sean and I am addicted to STXs smokeysevin's Avatar
    Join Date
    May 2008
    Location
    Houston
    Posts
    4,485
    +1
    320
    how old is the gas? if its a season old, drain and refill the tank

    Sean

  4. #4
    I filled her up right before the ride, are fuel injector cleaners safe and have they ever improved similar problem? thank you!

  5. #5
    my gas is brand new just filled it today...

  6. #6
    SCSFAB's Avatar
    Join Date
    Jan 2007
    Location
    ANKENY ,IA
    Posts
    112
    +1
    2
    did you pull or inspect the pump?

  7. #7
    the fuel pump?

  8. #8
    My name is Sean and I am addicted to STXs smokeysevin's Avatar
    Join Date
    May 2008
    Location
    Houston
    Posts
    4,485
    +1
    320
    check the jet pump for anything out of the ordernary, and look for any exhaust leaks

    Sean

  9. #9
    dreww's Avatar
    Join Date
    May 2007
    Location
    G.P.
    Posts
    182
    im thinking exhaust leak too. the fuel and plugs were first two suspects but ya'll checked that.

    did the ski sit in freezing conditions during winter?

  10. #10
    Quote Originally Posted by dreww View Post
    im thinking exhaust leak too. the fuel and plugs were first two suspects but ya'll checked that.

    did the ski sit in freezing conditions during winter?
    Yeah I live in Buffalo, NY so it does sit in freezing conditions.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 7
    Last Post: 07-25-2014, 11:20 PM
  2. Need help 2008 Kawasaki STX 15F shuts off while running
    By KGK in forum Kawasaki PWC Performance (4-stroke)
    Replies: 1
    Last Post: 07-04-2014, 10:05 PM
  3. Kawasaki STX-15F 2008 fuel warning light on
    By mcmurtrey in forum Kawasaki PWC Performance (4-stroke)
    Replies: 4
    Last Post: 08-03-2011, 11:33 AM
  4. 2008 Kawasaki STX-15F Speed?
    By Dallasmavs69 in forum Kawasaki Open Discussion
    Replies: 44
    Last Post: 09-23-2008, 09:07 AM
  5. 2008 Kawasaki STX-15F Impeller? PLEASE HELPP!!!
    By Dallasmavs69 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 1
    Last Post: 06-09-2008, 03:45 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •