Results 1 to 4 of 4

Thread: advent problems

  1. #1

    Join Date
    Jan 2006
    Location
    Denver, Colorado
    Posts
    47

    advent problems

    Anyone had any problems with there advent in an stxr. my has no spark, but advent tells me it's fine. Send help need to get boat on water.


  2. #2
    btldigger's Avatar
    Join Date
    Feb 2007
    Location
    lebanon tn.
    Posts
    1,641
    Do you have you stock cdi? if so plug it in and see if it works. Check your fuses to be sure you got power. You may want to check the trigger coil from the stator too. Btw there is a switch on that ignition to turn the spark on and off make sure it isnt off. Do you have a service manual?

  3. #3

    Join Date
    Jan 2006
    Location
    Denver, Colorado
    Posts
    47
    Thanks for answering. yup checked all that. i plug in my other cdi and i have spark. i sent my ignition back to advent and they told me everything was ok. i checked every switch twice. still no spark. I bought the ignition used so i dont have a manuel. the guuyi bought it from had never opened the bos. The only things i can think of is that the cdi is bad or i have something hooked up wriong. But i dont know what.

  4. #4
    btldigger's Avatar
    Join Date
    Feb 2007
    Location
    lebanon tn.
    Posts
    1,641
    There really is no way to hook it up wrong. If all the switches are set correctly then I would say the cdi is bad. Try posting a pic up close of the switches so we can see the settings.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. ADVENT Problems..
    By great lakes gpr 1200 in forum Yamaha PWC Performance (2-stroke)
    Replies: 11
    Last Post: 07-13-2008, 12:43 PM
  2. More Advent problems!!!
    By Duke in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 09-01-2007, 12:47 PM
  3. Advent Problems
    By OCFZR in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 05-08-2007, 07:03 AM
  4. Advent problems
    By Duke in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 09-25-2006, 10:39 PM
  5. Advent Problems
    By OCFZR in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 07-24-2006, 11:06 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •