Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 31
  1. #1
    ANASTY's Avatar
    Join Date
    Mar 2010
    Location
    High Rock Lake NC
    Posts
    28

    s/c bearing failed locked up motor advice

    Ok ive been chasing a problem with my ski. At the begining of summer i purchased a s/c with stg 3 wheel an 42# injectors from Cosmic on here to go along with my other mods. o8 exhaust, tdr through hull, riva grate, 14/19, kanaflex 4 in an the ski just didnt run like it should i thought. Wouldn't turn but 8000 an ran about 68. Pm'ed cosmic an he assured me the charger was in great shape blah blah blah an there was somethin else wrong with my ski, bc it would turn over 8100 with a 15/20 on his ski.. So i checked comp. 2 were 140 an 1 was 135. new plugs, swapped coils from another ski, checked for boost leaks found my riva bov was leaking blocked that still no change. checked for exhaust/ intake leaks couldnt find anything. So this past weekend i loaded up went to the beach with some friends rode friday and about an hour sat. an the motor locked up. Pulled it out of the water pulled the s/c an saw the fin had been hitting the housing just slightly. Turned the charger over an sure enough half the balls were gone from the bearing. I've probably put 10 hrs on this charger since getting from COSMIC. He said it had 20 hrs on it when i got it from him on a FULL REBUILD. So my question is where do these balls get wedged to lock the motor up tight? In between the oil pump gears or have they gone further? Do i need a full rebuild IE completely disassemble an while its apart what updates need to be done besides the oiler for the s/c? ski is an 07 rxp with 90hrs on it.


  2. #2
    GOT BOOST? Dockside's Avatar
    Join Date
    Dec 2008
    Location
    Ontario, Canada
    Posts
    3,879
    +1
    116
    S3 chargers are pron to touchdowns, do a search.... Everyone i found at one time had touched down and riva doesnt even make it anymore. also im not 100% sure but if you running the stock intercooler you dont need 42's

  3. #3

    Join Date
    May 2008
    Location
    metairie,la
    Posts
    709
    Quote Originally Posted by ANASTY View Post
    Ok ive been chasing a problem with my ski. At the begining of summer i purchased a s/c with stg 3 wheel an 42# injectors from Cosmic on here to go along with my other mods. o8 exhaust, tdr through hull, riva grate, 14/19, kanaflex 4 in an the ski just didnt run like it should i thought. Wouldn't turn but 8000 an ran about 68. Pm'ed cosmic an he assured me the charger was in great shape blah blah blah an there was somethin else wrong with my ski, bc it would turn over 8100 with a 15/20 on his ski.. So i checked comp. 2 were 140 an 1 was 135. new plugs, swapped coils from another ski, checked for boost leaks found my riva bov was leaking blocked that still no change. checked for exhaust/ intake leaks couldnt find anything. So this past weekend i loaded up went to the beach with some friends rode friday and about an hour sat. an the motor locked up. Pulled it out of the water pulled the s/c an saw the fin had been hitting the housing just slightly. Turned the charger over an sure enough half the balls were gone from the bearing. I've probably put 10 hrs on this charger since getting from COSMIC. He said it had 20 hrs on it when i got it from him on a FULL REBUILD. So my question is where do these balls get wedged to lock the motor up tight? In between the oil pump gears or have they gone further? Do i need a full rebuild IE completely disassemble an while its apart what updates need to be done besides the oiler for the s/c? ski is an 07 rxp with 90hrs on it.
    not good. NEVER buy a used charger on this site. i bought one myself a while back and had the same thing happen/without the bearings falling out. minor td. was told it had 3 hrs on it. THAT WAS BS.

  4. #4

    Join Date
    Jun 2010
    Location
    NC
    Posts
    42
    Quote Originally Posted by busa504 View Post
    not good. NEVER buy a used charger on this site. i bought one myself a while back and had the same thing happen/without the bearings falling out. minor td. was told it had 3 hrs on it. THAT WAS BS.
    Oh yeah, sound like this guy who sold it was full of BS also

  5. #5
    I sold the charger to this Guy. I bought it with 5 hours and put 15 on it so 20 hours total. I had no problems with the charger and I would have kept it if I didn't need the money. I hate that this happened but after the immature nasty PMs he sent me I'm over it (if posting Pms on here was allowed I'd share what a class act this guy isn't).

    This is the charger I sold him after I used it 15 hours. This was a bearing failure, not human error, no body's fault except the bearing Manufacture. My supercharger hoses had no aluminum dust in them. I mean zero. No bearing play either. I mean zero.
    http://greenhulk.net/forums/showthre...3-Supercharger

    The supercharger was advertised as S3 charger 20 hours on rebuild. I also said that I rebuilt it myself trying to avoid placing blame on anyone else. It's not about who built it after you use it.

  6. #6

    Join Date
    May 2008
    Location
    metairie,la
    Posts
    709
    well iguess its ironic how it happens, when your told it has 3 hrs on it and you put 5 on it and the bearings fail !! sounds like bs to me. that was my case.

  7. #7
    The bearing failed bottom line. I wish I could see into the future but I can't. All was fine untill he got it. Anyone else that has bought parts from me knows that I don't sell damaged goods. I myself got a used supercharger from here that touched down but I cought it in time. But I also didn't blame anyone but myself for buying it. I never even contacted the seller because it was fine untill the bearings started to wear out. not the sellers fault.

  8. #8
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    That charger was rebuilt with riva ceramic bearings ... I'm surprised that it even lasted 30 hrs Those bearings were absolute garbage... and most never made it to 20 hrs

  9. #9

    Join Date
    May 2008
    Location
    metairie,la
    Posts
    709
    Quote Originally Posted by BigDaddyRXP View Post
    That charger was rebuilt with riva ceramic bearings ... I'm surprised that it even lasted 30 hrs Those bearings were absolute garbage... and most never made it to 20 hrs
    bingo

  10. #10
    Richieb's Avatar
    Join Date
    Oct 2008
    Location
    Sydney, Australia.
    Posts
    1,001
    Y'no, sometimes things fail earlier than other identical items.

    There could be any number of contributing factors that lead to the demise of it.

    Most people on here, infact nearly all are good, honest people. Sometimes the way the item may have been shipped and thumped about can impact on the spinle shaft, and cause slight damage to the races, but it is very difficult to see if this has been the case.

    I would be more inclined to look at impact, or how the charger was rested on its side whilst resting against the spindle during transport etc. Ceramics are strong, like all bearings, but the forces from a slight tap sideways can bruise them.

    Maybe when shipped, the shaft can be protected via some kind of tubing over it, and fastened to the body of the charger.?

    BTW, the "Balls" can be stuck/jammed between teeth on the fly-wheel/balancer gear to lock it real good.

    Off with the PTO cover, and have a look around. Filter clean/replace, check oil pump clearance/damage, and then unbolt the scavenge pump, and do the same.

    If you can account for the "Balls", and all the bits add up to a whole one, then a flush thro will probably be sufficient to get back on the water.

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. locked up motor?
    By official_style in forum Yamaha Old School Skis
    Replies: 23
    Last Post: 08-04-2009, 05:45 PM
  2. 06 rxp motor stalled then locked up
    By blu 250x in forum 4-Tec Performance
    Replies: 23
    Last Post: 08-28-2008, 01:03 PM
  3. Bought a 2004 RXP Locked up motor.a few ??
    By spinyard in forum 4-Tec Performance
    Replies: 8
    Last Post: 07-15-2008, 02:17 PM
  4. Motor locked up?
    By JimC in forum 4-Tec Performance
    Replies: 26
    Last Post: 06-26-2007, 04:59 PM
  5. 96 GTI locked up motor
    By rayk in forum 2-Stroke Performance
    Replies: 5
    Last Post: 04-26-2007, 09:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •