Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1
    b_dolla44's Avatar
    Join Date
    Apr 2008
    Location
    Noblesville, Indiana United States
    Posts
    1,165
    +1
    15

    Tested 04 rxp mods....is this right???

    04 rxp
    167hours
    0 hours on riva metal washers
    mcmaster spring washers
    Slip set to 9.81 ft lbs
    riva stg2 gen 1 sc wheel
    home made free flow
    4 in kanflex/ no filter
    solas 14/19
    riva BOV
    water temp 85
    air temp 92 humidy high
    500 ft above sea level
    70.1 on gps
    turning 7750-7800 rpms
    rideplate filled, reverse trimmed, nose cone removed.
    STILL HAS OEM INTAKE, AND OPAS, NOT RUNNING A PUMP WEDGE
    rpms just seem low.... what do you guys think ??????? ???????????


  2. #2
    b_dolla44's Avatar
    Join Date
    Apr 2008
    Location
    Noblesville, Indiana United States
    Posts
    1,165
    +1
    15
    Bump...

  3. #3

    Join Date
    Oct 2009
    Location
    miami
    Posts
    715
    you need a intake grate get a riva

  4. #4
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,628
    +1
    808
    heat and humidity will kill your RPMs, especially with the stock intercooler. make sure the BOV is not leaking any boost.

  5. #5
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Quote Originally Posted by stevorxp007 View Post
    you need a intake grate get a riva
    Why So it'll break off

  6. #6

    Join Date
    Jan 2006
    Location
    Florida
    Posts
    526
    why do people still recomend that grate must whant it to break to.

  7. #7

    Join Date
    Jan 2006
    Location
    Florida
    Posts
    526
    rpms low so is speed. ski should dp that with nothing done

  8. #8
    b_dolla44's Avatar
    Join Date
    Apr 2008
    Location
    Noblesville, Indiana United States
    Posts
    1,165
    +1
    15
    So a grate would help my rpms?........is there another grate that I don't have to run the girddle with?

  9. #9
    h2jim's Avatar
    Join Date
    Nov 2008
    Location
    Ontario Canada
    Posts
    2,063
    +1
    61
    Sounds like you have a leak and the hummidity. Both will cause your RPM's to be down.

  10. #10
    b_dolla44's Avatar
    Join Date
    Apr 2008
    Location
    Noblesville, Indiana United States
    Posts
    1,165
    +1
    15
    Ok, so maybe the bov is leaking....it does have a small crack in the hose where the bov mounts. I did put soapy water on it and rev'd it up and didn't see it leaking....ill pull it tomorrow and make a test run on Friday....anyone else have any other ideas?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2008 RXP-X 71.5 mph. Is this right?
    By BobOnThis in forum 4-Tec Performance
    Replies: 41
    Last Post: 05-13-2015, 03:43 PM
  2. is this right??
    By mudd in forum Polaris Open Discussion
    Replies: 13
    Last Post: 10-26-2012, 04:30 PM
  3. R&D RXP Grate Is this right ?
    By David_HX_RXP in forum 4-Tec Performance
    Replies: 3
    Last Post: 10-23-2009, 08:18 PM
  4. Winterizing antifreeze flow. Is this right?
    By zone 5 in forum 4-Tec Performance
    Replies: 10
    Last Post: 11-06-2007, 05:51 PM
  5. 04 rxp mods
    By carl sagan in forum 4-Tec Performance
    Replies: 4
    Last Post: 07-15-2007, 11:00 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •