Results 1 to 9 of 9
  1. #1

    spark at 1 cyl. only 93 650

    Well got engine back together with new stator and dunked in ski. New batt. Decided to check for spark first then go from there. Needless to say I've only got spark at pto cly. with all 3 coils hooked up in series.Now if I disconnect cdi wires and plug them into each coil seperately all coils fire.from what I have read all 3 should fire at same time? if so then that rules out cdi being bad if it fires 1 cly. when they are in series right? Coils will fire if hooked up seperately so they are good right? WTF is the problem. The stator was "new" in box for a 92 and cdi in ski is for a 93 could that be it? Any input would be apprecated. I'm at a loss. I think I'll stick to snowmobiles as I've never incountered these kind of problems before with them. Nate
    Last edited by mopar2256; 07-06-2010 at 03:30 PM. Reason: added more info.


  2. #2
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,327
    +1
    29
    That's really odd.

    Wired in series, yes, they all should fire at the same time.

    Just for the Hell of it, ohm test the coils.

    Have you tried cutting the plug wires back about 1/4" to expose new wire to the plug boots?

    You don't have a coil wire that the insulation is pulled back and can be arcing or grounding do you?

  3. #3
    Xlint, right on went out and checked wires mag cyl. taped up under plastic wrap cut it back and no change. pulled it out of coil cut itoff there and got spark. Nothing at center cyl. though. did same to it and got fire at all three but pto has best spark. Have to replace wires now too short but think problem is solved for now. Is it common to take alot of cranking of engine to purge oil lines of air? Mine are just now full. Nate

  4. #4
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,327
    +1
    29
    It's normally not common practice to pull the plug wires out of the coil. They are actually glued in.

    Maybe look in the classifieds for some good used coils w/wires, or contact John Zigler.

    Best bet is to pour a little premix into the carbs to get it running, and that will prime the oil lines much faster without putting any undo stress on your starter and battery.

  5. #5
    thanks for advice I p.md some guys on here about coils. I can buy new 1's for $33 a peice at dennis kirk so might go that route. Nate

  6. #6
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,327
    +1
    29
    I bet you can get good used ones for around $30 a set.

    Any 650/750/780 coil will work all the same

  7. #7
    Quote Originally Posted by xlint89 View Post
    I bet you can get good used ones for around $30 a set. they are aking $25 a piece shipped/ $30+ on ebay

    Any 650/750/780 coil will work all the same
    thanks for info.

  8. #8
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,327
    +1
    29
    Check the classifieds on here or contact John Zigler and see how much he wants for a set.

  9. #9
    Did classifeds $75 set shipped so far. As for John done business in past have not seen anything on his site. this is where I found them cheeper. Thanks, Nate http://shop.hyperformanceparts.com/s...FUf75wodWVp6xAthanks,Nate
    Last edited by mopar2256; 07-08-2010 at 10:29 PM. Reason: make sure link worked

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. No spark on center cyl - 1200 slx
    By ryanbgb22 in forum Polaris Open Discussion
    Replies: 17
    Last Post: 05-07-2010, 01:24 PM
  2. Alarms at high speed only, FI
    By eddiej0nes in forum Honda Open Discussion
    Replies: 5
    Last Post: 04-21-2008, 10:57 AM
  3. spark plugs and vibrations on 93 SL 750
    By jmule98 in forum Polaris How To & FAQs
    Replies: 2
    Last Post: 08-27-2007, 11:54 PM
  4. 93 650 sl di wiring digram.
    By biggbearbc in forum Polaris How To & FAQs
    Replies: 3
    Last Post: 07-24-2007, 08:26 PM
  5. crankcase seal 93 650 polaris
    By tomm in forum Polaris How To & FAQs
    Replies: 8
    Last Post: 05-16-2007, 04:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •