Results 1 to 5 of 5
  1. #1

    battery not charging on R12X

    Hi everyone,

    I have a 2004 R-12X and the battery warning came on and my engine died.

    Installed a new (and charged) Yuasa Battery yesterday, and after about 45 minutes of riding, the warning came on again.

    I have zero experience diagnosing electrical issues, but figure this should be something I can track down with some help.

    I have read this could be the voltage regulator (is this the same as the rectifier)? Should I just install a new one and see what happens, or is there a more strategic way to diagnose this?

    Thanks in advance for any help.


  2. #2
    Moderator
    I build Horsepower
    NitroShark's Avatar
    Join Date
    Jan 2006
    Location
    Greenville,SC
    Posts
    1,388
    +1
    13
    You need a DC Volt meter (VOM)

    Check the voltage (at the battery) when the ski is off. Then start and read it at idle. Hold the throttle to 3000 RPM, take a reading. then briefly do the same at 4500 RPM

    The voltage should show an increase after 3000 or soo RPM.

    If not, most likely the voltage regulator is bad. Seen it happen before, pretty common But before you replace it, check for corroded connections and report your voltage readings here.

    I have more checks after to post back

    Shawn

  3. #3
    Thanks for the tips, and sorry for the slow reply. It took me awhile to get someone on the water with me to run these tests (I dock my ski, I don't trailer it).
    Anyway, When the engine is off, at idle, 3000 RMP, and 4200 RPM, the voltage is 12.4.

    New voltage regulator?

  4. #4
    HI Nitro,

    Any other advice here?

    Thanks in advance.

  5. #5
    Moderator
    I build Horsepower
    NitroShark's Avatar
    Join Date
    Jan 2006
    Location
    Greenville,SC
    Posts
    1,388
    +1
    13
    Quote Originally Posted by gregdole7 View Post
    New voltage regulator?
    Yes, it is bad


    Shawn

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. battery not charging 05 rxp
    By pantydropper in forum 4-Tec Performance
    Replies: 17
    Last Post: 06-30-2010, 04:55 PM
  2. Battery not charging
    By chopper400ex in forum Polaris Open Discussion
    Replies: 2
    Last Post: 07-15-2009, 10:00 AM
  3. Ultra 150 Battery not charging/battery light flashing
    By kcoleman10 in forum Kawasaki Open Discussion
    Replies: 5
    Last Post: 02-13-2009, 01:18 AM
  4. battery not charging on 1999 gsx
    By scott o in forum 2-Stroke Performance
    Replies: 1
    Last Post: 07-22-2007, 01:50 PM
  5. Need help, No rpm's, not charging on mfd
    By gvnitup in forum Polaris Open Discussion
    Replies: 12
    Last Post: 05-22-2007, 12:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •