Results 1 to 7 of 7
  1. #1
    sweetbats's Avatar
    Join Date
    Mar 2008
    Location
    Glen Allen, VA
    Posts
    238

    Bailer Hose one way valve not working

    Can water enter the hull if the one way valve on an 05 RXP stock bailer system fails? I could blow air through both ends of one of the bailers. One side works perfectly, the other is a 2 way valve!

    I am currently changing out the pump shoe and aligning it along with the motor.

    Over the winter I replaced carbon seal and added Jim's ride plate only to end up with water in the hull.

    I powered up with a B kit and my speeds increased, but so did my water intake!

    I have read a lot of posts and know that chasing down a water leak can be a real headache.

    I will check and adjust the following:
    Bailer system
    OPAS block offs
    Drain plugs
    Ride plate
    Carbon seal
    Pump shoe
    Exhaust system


    Anything I am missing?

    Thanks in advance!


  2. #2
    home of the dislexic fingers breon's Avatar
    Join Date
    Aug 2007
    Location
    port st lucie fl
    Posts
    3,471
    seem to be having the same problemthe balls were stuck..and stuck hard..un stuck them and i think they have stuck again

  3. #3
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    What are bailers Rip that worthless shit outta there & toss in a bilge pump

  4. #4
    sweetbats's Avatar
    Join Date
    Mar 2008
    Location
    Glen Allen, VA
    Posts
    238
    I do have a bilge pump installed. I am concerned about water coming in at all.
    Let's stop water coming in first, so I don't have to rely on the automatic Rule bilge pump. Keeping the hull dry is my goal. =)

  5. #5
    ABSOF*CKINLUTELY enjoisht's Avatar
    Join Date
    Mar 2010
    Location
    Delaware
    Posts
    148
    did you check the intercooler water lines? that back one you cannot see i always reach in and feel around the fitting every once in a while to make sure its not wet...

  6. #6

    Join Date
    Jul 2006
    Location
    Beaufort, SC
    Posts
    592
    yea my check valves are like that too, cant seem to find decent replacements though

  7. #7
    Raventech's Avatar
    Join Date
    Jun 2009
    Location
    Southern, Ontario
    Posts
    60
    Quote Originally Posted by BigDaddyRXP View Post
    What are bailers Rip that worthless shit outta there & toss in a bilge pump


    +1

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Gp1200r power valves not working
    By Bubbaflaat in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 07-15-2013, 11:21 PM
  2. WTB Looking for the one way valve
    By Lvnspeed in forum Yamaha Classifieds
    Replies: 9
    Last Post: 09-20-2011, 08:51 AM
  3. Power valves not working
    By yamadood in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 05-10-2011, 08:37 PM
  4. How do I get the little one way valves back in my mikuni 44?
    By cigarlust in forum Kawasaki PWC Performance (2-stroke)
    Replies: 4
    Last Post: 06-16-2009, 12:23 PM
  5. "HELP" Power Valves not working or trim tabs???
    By unscorpio40 in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 10-06-2008, 01:42 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •