Results 1 to 4 of 4
  1. #1

    1998 xpl cutting out losing power

    it starts and idles fine then when you rev it up at about 4 thousand rpm it beeps twice and dies loses all power then i put the key back on and it starts up fine and does it again as soon as you get into the revs it cuts off i changed the dess post that didnt do it im lost here any help or ideas would be of great help


  2. #2
    Work Harder, Millions on Wellfare Depend On Us! ultramaxracing05's Avatar
    Join Date
    Aug 2009
    Location
    Beaumont, Texas
    Posts
    2,999
    +1
    123
    does it cut out even if you let it idle for a while?

  3. #3
    no it idles fine its just when you get in the power,i cant figure it out

  4. #4
    Work Harder, Millions on Wellfare Depend On Us! ultramaxracing05's Avatar
    Join Date
    Aug 2009
    Location
    Beaumont, Texas
    Posts
    2,999
    +1
    123
    sounds like something electrical then, bro I know they need power from the battery to stay running, I would try putting a voltmeter on the battery while the ski is off, and then turn it on and see if its even charging

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2000 Polaris Virage cuts out loses spark
    By sltfan777 in forum Polaris PWC Performance
    Replies: 8
    Last Post: 07-19-2014, 04:11 PM
  2. FS 1998 XPL Hull with Title and Part out..
    By Seadooracer9 in forum Sea Doo 2 Stroke Skis
    Replies: 6
    Last Post: 04-26-2011, 10:34 AM
  3. FS 1998 XPL 947cc Part out
    By Dirty Sanchez in forum Sea Doo Classifieds
    Replies: 1
    Last Post: 11-07-2010, 07:23 AM
  4. Ski cutting out and losing power
    By TankerDriver in forum Polaris PWC Performance
    Replies: 6
    Last Post: 08-28-2009, 12:10 PM
  5. Replies: 18
    Last Post: 05-19-2009, 10:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •