Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15

Thread: too much oil?

  1. #1

    too much oil?

    hey guys. i have a 2010 fzs. have had it for about 3 weeks now.

    first day out with the ski, before i rode it i quickly checked the oil level after dropping the ski into the water. i thought the ski would be as level as possible while sitting in calm water. as far as i can remember the level was good.

    after putting 10 hours on the ski i attempted the first oil change. i was only able to extract a bit over 2 quarts. i measured what i removed and replaced with amsoil 10w-40 motorcycle synthetic since i could not find amsoil marine locally.

    this morning i figured i would attempt to remove replace a larger quantity of oil. using a smaller tube with my extractor i was able to remove over 3.5 quarts. i replaced what i removed.

    i checked the oil a few times and it kept looking like it was over filled by, what i thought, to be a small amount. i figured maybe the engine needed to be run to circulate the oil, so i took the ski out for the evening and rode for about 2 hours.

    when i got home i precisely leveled the ski (level across the coil packs) and checked the level several times. it still read high on the dip stick. only after removing just shy of an entire quart did the dipstick indicate the proper level - right at the top hash for "full".

    my questions are

    a) have i done any serious harm running the engine for an unknown amount of time with too much oil.

    b) am i incorrectly checking the oil level? i read the service manual and i don't think i am missing anything...

    i am just stumped as to how i would somehow end up with literally an extra quart in there? unless it was over filled when i bought it?

    i can't remember if i checked the oil level after the first oil change...i would like to think that i did and that it was ok....

    the only thing i can think of is that today when i was measuring and replacing the oil that i extracted that i miscounted the quarts and put an extra in..... but we are not talking about large numbers, so....


  2. #2

    Join Date
    Jan 2007
    Location
    Kansas
    Posts
    394
    +1
    11
    Sounds like GIO (gas in oil) have you done any mods to it?

  3. #3
    hitman's Avatar
    Join Date
    Aug 2006
    Location
    Ft. Lauderdale, FL
    Posts
    4,328
    +1
    12
    Quote Originally Posted by kansasgpr View Post
    Sounds like GIO (gas in oil) have you done any mods to it?
    I'm guessing he doesn't since he's only had it for about 3 weeks and makes no mention of any mods so I seriously doubt it's GIO.

    If you over fill the oil you are probably fine. It will usually only cause you to be slightly down on RPMs. Just pull some out. After running the engine at normal operating temp, shut it off and check the oil after a couple minutes. It should read at the full level.

  4. #4
    no - zero modifications.

    i did remove the excess oil.

    i will keep a very close eye on the level to make sure i did not remove too much.

    mods are to come figured i would ride this season stock and have the winter to save up for some goodies.

  5. #5
    by the way, hitman. really nice truck and matching ski... looks killer.

  6. #6
    gmoeller's Avatar
    Join Date
    Nov 2007
    Location
    Hermosa Beach, Calif
    Posts
    1,450
    +1
    9
    Quote Originally Posted by hitman View Post
    I'm guessing he doesn't since he's only had it for about 3 weeks and makes no mention of any mods so I seriously doubt it's GIO.

    If you over fill the oil you are probably fine. It will usually only cause you to be slightly down on RPMs. Just pull some out. After running the engine at normal operating temp, shut it off and check the oil after a couple minutes. It should read at the full level.
    +1

  7. #7
    C Dawg222's Avatar
    Join Date
    Oct 2008
    Location
    Baton Rouge, LA
    Posts
    470
    +1
    19
    Quote Originally Posted by mwahlert View Post
    hey guys. i have a 2010 fzs. have had it for about 3 weeks now.

    first day out with the ski, before i rode it i quickly checked the oil level after dropping the ski into the water. i thought the ski would be as level as possible while sitting in calm water. as far as i can remember the level was good.

    after putting 10 hours on the ski i attempted the first oil change. i was only able to extract a bit over 2 quarts. i measured what i removed and replaced with amsoil 10w-40 motorcycle synthetic since i could not find amsoil marine locally.

    this morning i figured i would attempt to remove replace a larger quantity of oil. using a smaller tube with my extractor i was able to remove over 3.5 quarts. i replaced what i removed.

    i checked the oil a few times and it kept looking like it was over filled by, what i thought, to be a small amount. i figured maybe the engine needed to be run to circulate the oil, so i took the ski out for the evening and rode for about 2 hours.

    when i got home i precisely leveled the ski (level across the coil packs) and checked the level several times. it still read high on the dip stick. only after removing just shy of an entire quart did the dipstick indicate the proper level - right at the top hash for "full".

    my questions are

    a) have i done any serious harm running the engine for an unknown amount of time with too much oil.

    b) am i incorrectly checking the oil level? i read the service manual and i don't think i am missing anything...

    i am just stumped as to how i would somehow end up with literally an extra quart in there? unless it was over filled when i bought it?

    i can't remember if i checked the oil level after the first oil change...i would like to think that i did and that it was ok....

    the only thing i can think of is that today when i was measuring and replacing the oil that i extracted that i miscounted the quarts and put an extra in..... but we are not talking about large numbers, so....
    Mine was overfilled from the dealer by well over a quart...didn't notice it til my first oil change, when I put back in the same amount that I removed. NEVER trust the dealer!

  8. #8
    hitman's Avatar
    Join Date
    Aug 2006
    Location
    Ft. Lauderdale, FL
    Posts
    4,328
    +1
    12
    Quote Originally Posted by mwahlert View Post
    by the way, hitman. really nice truck and matching ski... looks killer.
    Thanks man.

    Nevermind the gay avatar either. I think I got pwned by the Hulk himself... AGAIN! lolz

  9. #9
    TheXrider's Avatar
    Join Date
    Dec 2007
    Location
    Miami, Florida, United States
    Posts
    305
    I checked my oil the other day a few hours after changing the oil and taking it for a ride and it was overfilled and it smelled like gas. It's an 09 FZR with 40 hrs and I think i'm having serious issues with GIO. I have a few mods like aftermarket intercooler with hks blow off valve, Riva power filter, Riva thru hull and R&D Engine/ intercooler cooling kit, intake grate and ride plate other than that everything else is stock.. I think that it might be related to the engine maybe running to cool with the extra cooling. What other things could be causing GIO?

  10. #10
    gmoeller's Avatar
    Join Date
    Nov 2007
    Location
    Hermosa Beach, Calif
    Posts
    1,450
    +1
    9
    Quote Originally Posted by TheXrider View Post
    I checked my oil the other day a few hours after changing the oil and taking it for a ride and it was overfilled and it smelled like gas. It's an 09 FZR with 40 hrs and I think i'm having serious issues with GIO. I have a few mods like aftermarket intercooler with hks blow off valve, Riva power filter, Riva thru hull and R&D Engine/ intercooler cooling kit, intake grate and ride plate other than that everything else is stock.. I think that it might be related to the engine maybe running to cool with the extra cooling. What other things could be causing GIO?
    http://www.greenhulk.net/forums/show...ued.&highlight=

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1995 Waveraider 1100 getting too much oil/Mechanic suggestions?
    By jasond32 in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 07-06-2009, 09:34 PM
  2. How much is too much oil
    By Full Throttle in forum Yamaha PWC Performance (2-stroke)
    Replies: 12
    Last Post: 10-14-2008, 09:21 PM
  3. 97 wave venture... too much oil.
    By neitzey101 in forum Yamaha Old School Skis
    Replies: 5
    Last Post: 08-20-2008, 07:06 PM
  4. Too much oil
    By mustang5x0 in forum 4-Tec Performance
    Replies: 17
    Last Post: 07-15-2008, 07:34 PM
  5. Snapper or anyone else, too much oil fix?
    By Whiplash in forum Kawasaki PWC Performance (4-stroke)
    Replies: 23
    Last Post: 06-03-2007, 01:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •