Results 1 to 7 of 7

Thread: MPEM Fault

  1. #1

    Join Date
    Sep 2009
    Location
    Lafayette,La
    Posts
    23

    MPEM Fault

    I have a 2005 RXT stock. I have started getting a sensor indication. When I retreive the codes they are P1517 and P1607. P1517 is compass out of range. I have no compass, and 1607 is MPEM fault. The ski seams to run fine, I just always have these two faults. Any ideas?


  2. #2
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,518
    +1
    1,267
    I've seen this type of fault on a number of 2005's.just an annoyance it seems. dealer can clear it if you ever have an opportunity to get hooked up to buds.

  3. #3
    Richieb's Avatar
    Join Date
    Oct 2008
    Location
    Sydney, Australia.
    Posts
    1,001
    +1

  4. #4

    Join Date
    Sep 2009
    Location
    Lafayette,La
    Posts
    23
    It is very annoying to get the sensor and beeps every time you put the dess on the post.

  5. #5

    Join Date
    Sep 2009
    Location
    Lafayette,La
    Posts
    23
    There are no faults recorded in the MPEM. I cleared the faults anyway, and I still get the two codes when the key is put on the DESS post. Also get what seems to be 4 short beeps with a few sec delay between it being repeated over and over. Any ideas?

  6. #6
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,518
    +1
    1,267
    you'll find in the owners manuals that the 4 beeps are a reminder that you've left the ignition key on the post. If it's really really really annoying you can take it to a dealer or a friend with buds and tell the console there is no compass installed.

  7. #7

    Join Date
    Sep 2009
    Location
    Lafayette,La
    Posts
    23
    I guess I assumed the beeps went with ' sensor ' being displayed every time I powered up.
    I understand the compass needs to be disabled (also shows depth in the list of modes that can be displayed) and that to can be removed too, but what about the P1607 MPEM fault? Could this be related to the compass fault?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. How To: Wire into the MPEM for switched power source.
    By rapidacceleration in forum Sea Doo How To & FAQs
    Replies: 30
    Last Post: 08-24-2012, 06:29 PM
  2. seadoo gtx rfi 2001 MPEM corrosion fault code
    By snowsports1 in forum 2-Stroke Performance
    Replies: 8
    Last Post: 09-21-2011, 09:10 AM
  3. seadoo gtx rfi 2001 MPEM corrosion fault code
    By snowsports1 in forum 2-Stroke Performance
    Replies: 0
    Last Post: 09-19-2011, 03:05 PM
  4. p 1607 MPEM Fault?
    By ARNYGOLLOTT3 in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-18-2008, 01:57 PM
  5. Coinsidence or my fault?? Opinions needed desperately
    By Fuhreal in forum Sea Doo Open Discussion
    Replies: 17
    Last Post: 07-03-2006, 08:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •