Results 1 to 6 of 6
  1. #1

    When i get up on plane........

    1996 sltx
    ski sat for awhile but operable once again.
    new plugs
    clean fuel
    new jet pump
    new shaft
    new battery

    ok problem..

    ski puts around fine.
    but when i start to get on plane it feels like the pump is staving for water.
    goes high rpm and propulsion is lost but engine still runs.

    in bike or car terms...

    its like im spinning my wheels when i try to get on plane.
    oddly.
    when i make sharp turns left or right i can get full throttle.
    just when i try to get on plane...


    any suggestions on trouble shooting?
    i have all the manuals but looking for some expert help here.

    TIA


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,593
    +1
    1,275
    Was the jet pump base removed from the hull?

    If yes, was it resealed to the hull?

    Was the through-hull bearing assembly rebuilt with new seals?

    Have a look here;
    Importance of carefully sealing ride plate and jet pump intake to prevent ventilation

  3. #3
    Quote Originally Posted by K447 View Post
    Was the jet pump base removed from the hull?

    If yes, was it resealed to the hull?

    Was the through-hull bearing assembly rebuilt with new seals?

    Have a look here;
    Importance of carefully sealing ride plate and jet pump intake to prevent ventilation

    thanks. that link helped alot.
    yes the pump was removed.
    reading the link provided

    think a good remove ride plate and reseal everything MAY fix everything..
    will do that and update later after dry time and testing..

    what commonly available silicone to you recommend?

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,593
    +1
    1,275
    Quote Originally Posted by Mecha View Post
    ...yes the pump was removed.

    think a good remove ride plate and reseal everything MAY fix everything..
    will do that and update later after dry time and testing..

    what commonly available silicone to you recommend?
    The jet pump stator + impeller section comes off after removing four long bolts. The pump base is sealed to the hull and held in place with four nuts. Which did you remove?

    Was the pump base removed from the hull?

    Was the hull damaged near there?

    I don't understand how wave jumping could damage the ride plate and intake grate, unless the hull hit something hard.

    Use a Marine grade sealant, not household stuff.

    Do not use 3M 5200 - it is like cement when hardened.

  5. #5
    Quote Originally Posted by K447 View Post
    The jet pump stator + impeller section comes off after removing four long bolts. The pump base is sealed to the hull and held in place with four nuts. Which did you remove?

    Was the pump base removed from the hull?

    Was the hull damaged near there?

    I don't understand how wave jumping could damage the ride plate and intake grate, unless the hull hit something hard.

    Use a Marine grade sealant, not household stuff.

    Do not use 3M 5200 - it is like cement when hardened.

    never said wave jumping damaged anything...
    the bearing in the rear of the jet pump died so yes we removed the entire jet pump from the hull
    no the hull isnt damaged at all

  6. #6

    Join Date
    Sep 2006
    Location
    topeka,ks
    Posts
    3,332
    good splines on your coupler ?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 9
    Last Post: 08-26-2011, 09:33 AM
  2. When do you give up on rebuild and just part out?
    By toyterrific in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 08-08-2010, 07:07 PM
  3. Sl750 must feather throttle to get on plane
    By skigolfnut in forum Polaris Open Discussion
    Replies: 23
    Last Post: 01-27-2010, 10:16 PM
  4. Engine free revs untill its gets up to plane
    By 1gsx422 in forum 2-Stroke Performance
    Replies: 14
    Last Post: 09-09-2009, 07:38 PM
  5. RXP Hull lean when pushing up on plain
    By Antiguan FZR in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 03-10-2009, 07:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •