Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1

    15f dipping oil, water in cylinders, battery gets low

    Hi guys, after put my 15f in water I forgot to put the drain plugs and ran the ski until I feel something different, removed the seat and found water inside hull (water just gets to the driveshaft tall but I got aftermarket air filter so I think water ingestion cause this filter)so I took the ski to the trailer, drain the hull, tried to start and it had low battery (hydrolocked). So I took it home, remove the plugs, put it a jumper and I did crank it and water came out from the holes, I cheked oil and it did looks clean and level ok, after too many cranks and water completely out from cylinders I put everything in place and started the engine, shut oof, and started again about 5 times, no problems at all, at the end of this procedure Oil still looks clean no milky.

    I took it to the water again, ski ran great but after some riding I did stop the engine and when I tried to re-start had low battery again, so I put jumpers and start it, I did some WOT rides and when I stop the engine no re-start it had low battery again (I think rectifier but I checked and at 3500rpm 13.4v)When I was going to put jumpers again I noticed milky oil in the bottom of the engine bay, It did look like oil dipping all over the right side (like oil coming out from the tank oil with pressure) doesn't look like oil leak. So I better took ski to home, I did check oil level and It was low and little milky, remove spark plugs, crank it with jumpers and water come out from the holes AGAIN. Remove the intake manifold and It was dry (no water no oil).

    Battery is in good conditionsIt holds charge between weeks, but when I put ski in water then it gets low (or is hydrolocked engine?), Do I just do Oil changes until everything cleans up and problem solved?

    At the second time I did not have water inside hull so I don't know how water gets in my cylinders and oil, do you think I got a blown headgasket?
    Ski ran normal to me, its just this oil problem inside hull and water in cylinders I think battery cant crank the engine because it has high compression with water inside.

    Help me please!!!

    mods> aftermarket air filter, r&d emission Block off valves, big U bent (too tall, may be at valve cover tall) removing secondary water box (I think this U bent did water returns to exhaust cause it's too tall).

    Or I just pull engine out and open it?


  2. #2
    Did you find anything out with your problem ? I think I am battling a similar issue, but mine developed what sounded like a rod knock to me? I am very frustrated. I didnt leave my plugs out, but a cooling line blew off and filled my ski. I have a feeling I am need of a rebuild and I have only put three hours on my ski since I bought it a week ago....

  3. #3
    My name is Sean and I am addicted to STXs smokeysevin's Avatar
    Join Date
    May 2008
    Location
    Houston
    Posts
    4,486
    +1
    320
    sounds to me like you have a bad seal in your oil cooler, is this a salt water boat? thats the only way you could get water in the oil and oil in the hull at the same time

    Sean

  4. #4
    Well I came from change my engine oil, I changed 3 times and now looks clean, At the same time I removed the oil cooler to check seals, and everything was ok, I cleaned and reintalled.

    I´m going to check tomorrow if oil gets milky again or water in cylinders.


    I keep you posted!

    Lalo

  5. #5
    My name is Sean and I am addicted to STXs smokeysevin's Avatar
    Join Date
    May 2008
    Location
    Houston
    Posts
    4,486
    +1
    320
    do you ride salt water?

    Sean

  6. #6
    Usually a few months ago I used the ski in salt water but after that I´m just using it in the lake, when I removed the oil cooler the water side had some signs of salt in the metal, I cleaned very well and installed again, so far there no was any leak in the oil cooler.

    I didn´t have time today to check the ski in the lake, I´ll hope do it in the next days
    .

    The oil in the hull looks like came from the oil can, I think when my engine ingested water and I leaved for some hours the water falls between the rings to the oil pan, then oil-water was overfilled so the oil can puts out all the overfilled by the small filter dipping oil all over the place. well that´s why i think (i hope this theory is true so there is no internal damage haha)


    Lalo!

  7. #7
    My name is Sean and I am addicted to STXs smokeysevin's Avatar
    Join Date
    May 2008
    Location
    Houston
    Posts
    4,486
    +1
    320
    did you take apart the oil cooler and check the seals? you may have gotten water in through the catch can but I remember you saying it didnt get that high correct?

    Sean

  8. #8
    yes I took oil cooler apart and check the seals, no problem with them. You are right about the high of the water in the hull, it only gets to the driveshaft no more.

    Well I[m coming from the lake, and again battery gets low (I checked and ski was chargin it 13.4v at 3500rpm)

  9. #9
    My name is Sean and I am addicted to STXs smokeysevin's Avatar
    Join Date
    May 2008
    Location
    Houston
    Posts
    4,486
    +1
    320
    the battery is new correct? what type of battery is it? after reading your initail post again it sounds like you have a dead battery that isnt providing enough juice at start up, it will read normal when riding but it doesnt have the same cranking power as it used to. It seems to me that you had 2 seperate problems you were connecting as one

    Sean

  10. #10
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    also having a filter on the catch can is not going to help your oil problem in the hull thats exactly were the oil will end up with that filter.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2004 stx15f getting water in cylinders
    By 2004stx15f in forum Kawasaki How To & FAQs
    Replies: 4
    Last Post: 08-28-2016, 06:43 PM
  2. 2004 stx15f getting water in cylinders
    By 2004stx15f in forum Kawasaki PWC Performance (4-stroke)
    Replies: 3
    Last Post: 07-14-2016, 04:02 PM
  3. 2012 RXPX Problems - oil leaking, water in cylinders - Please Help!!
    By NBD Watersports Inc in forum 4-Tec Performance
    Replies: 1
    Last Post: 08-30-2013, 06:31 AM
  4. 06 rxp water in cylinders and oil help please
    By blue5speed in forum 4-Tec Performance
    Replies: 7
    Last Post: 01-04-2008, 09:45 AM
  5. Keep Getting Water In Cylinders
    By ezrider060 in forum 2-Stroke Performance
    Replies: 2
    Last Post: 06-09-2007, 12:21 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •