Results 1 to 5 of 5
  1. #1

    Join Date
    Aug 2008
    Location
    Northeast Ohio
    Posts
    11

    03 GP1300R Won't even crank/No Power

    Not sure what happen, but my ski just quit on me. I don't get any display or the motor won't even crank, like there isn't a battery connected. I have no idea what it could be, I'm going to try swapping out the battery first, but it was fully charged.
    Does anyone have any idea or tips I could try?
    Thanks in advacne


  2. #2
    Mike xsockguyx's Avatar
    Join Date
    Sep 2007
    Location
    NJ
    Posts
    1,744
    +1
    2
    Check the fuses on your electrical box. I bet one blew

  3. #3

    Join Date
    Aug 2008
    Location
    Northeast Ohio
    Posts
    11
    Thanks XSOCKGUYX, it was a fuse that fell loose in the choppy waters. I was trying to get the cap off but it was choppy and getting dark fast so I had someone pull me in. This morning saw that the fuse fell out, thanks for the tip!

  4. #4
    Mike xsockguyx's Avatar
    Join Date
    Sep 2007
    Location
    NJ
    Posts
    1,744
    +1
    2
    Quote Originally Posted by ESugar View Post
    Thanks XSOCKGUYX, it was a fuse that fell loose in the choppy waters. I was trying to get the cap off but it was choppy and getting dark fast so I had someone pull me in. This morning saw that the fuse fell out, thanks for the tip!

  5. #5

    Join Date
    Jan 2010
    Location
    queenz nyc
    Posts
    135
    hey guys , im having the same problem but a little differnt ,, same with no power but even worst ,, my fuse are ground now and when i send power to it , it fires up ??????????

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 96 ZXi will not crank? Won't even click. Where to start?
    By BudL1te in forum Kawasaki PWC Performance (2-stroke)
    Replies: 8
    Last Post: 07-08-2012, 02:55 PM
  2. Replies: 5
    Last Post: 07-04-2012, 09:59 AM
  3. GP800X & gp122X no power & won't run
    By jetskihero in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 08-01-2011, 12:10 PM
  4. No power won't go past 6000 rpms help!!
    By tocullo in forum 4-Tec Performance
    Replies: 34
    Last Post: 03-10-2011, 03:48 PM
  5. gp1300r no power over 4500rpm
    By sidewinder73 in forum Yamaha How To & FAQs
    Replies: 7
    Last Post: 08-05-2009, 04:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •