Results 1 to 4 of 4
  1. #1
    AaronC's Avatar
    Join Date
    Aug 2006
    Location
    Sacramento, CA
    Posts
    457
    +1
    4

    15f pump questions

    I ran into something interesting and want to throw out some ideas and get some feedback. A few weeks ago I was out still tuning the adjust a thrust. I had been trying every shuttle and bolt length combo out on gps for about a month. It ran best with the short bolt and short shuttle. GPS was avg around 62.7, 62.8 range. So at that point it picked up 1.2 mph on avg with the impeller and AAT. Then I got the idea of running without a shuttle. So I take it out and it picked up everywhere! The ski yanked harder than ever and instantly ran 63.8 and 63.9 on the stock ride plate. I emailed bruce at wetwolf and he said it sounds like I'm overstuffing the pump. I thought about it for a while and things started making some sense. The faster you go the more "ram" effect you get into the pump which means the pump needs to be able to move that water.

    So now my setup is the 13.5/20 impeller and no shuttle. Now I'm thinking of going to a taller impeller (maybe 14/21 or 14/22) and boring the exit nozzle. This in theory, should move more of that backed up water, reducing drag, and provide more thrust. What are your thoughts people?

    I have since added the R&D ride plate and that helped A LOT. I haven't GPS'd it since but it really moves and handles much better!
    Last edited by AaronC; 10-06-2006 at 04:04 PM.


  2. #2

    Join Date
    Sep 2006
    Location
    down under
    Posts
    645
    +1
    15
    Maybe bore the nozzle to unstuff the pump a bit and re-install the shuttle?

  3. #3
    AaronC's Avatar
    Join Date
    Aug 2006
    Location
    Sacramento, CA
    Posts
    457
    +1
    4
    How much do you think I should bore?

  4. #4

    Join Date
    Sep 2006
    Location
    down under
    Posts
    645
    +1
    15
    I have no idea. I have never seen an adjusta thrust in Australia but understand how they work. Send an email to aat explaining your results. They would be your best source of info.

    cheers, eel.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 7
    Last Post: 07-25-2014, 11:20 PM
  2. 15F Pump Bearing Install Concerns/Questions
    By kawa900stx in forum Kawasaki PWC Performance (4-stroke)
    Replies: 1
    Last Post: 07-23-2013, 08:33 AM
  3. Bilge Pump Questions
    By Piney in forum Sea Doo Open Discussion
    Replies: 20
    Last Post: 03-18-2006, 09:33 AM
  4. pump question
    By rxpblast in forum 4-Tec Performance
    Replies: 6
    Last Post: 01-11-2006, 09:37 PM
  5. pump question
    By skillet in forum 4-Tec Performance
    Replies: 16
    Last Post: 01-06-2006, 11:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •